PAT A1102. Invert a Binary Tree (25) [树的遍历]

The following is from Max Howell @twitter:

Google: 90% of our engineers use the software you wrote (Homebrew), but you can’t invert a binary tree on a whiteboard so fuck off.

Now it’s your turn to prove that YOU CAN invert a binary tree!
Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10) which is the total number of nodes in the tree – and hence the nodes are numbered from 0 to N−1. Then N lines follow, each corresponds to a node from 0 to N−1, and gives the indices of the left and right children of the node. If the child does not exist, a - will be put at the position. Any pair of children are separated by a space.

Output Specification:
For each test case, print in the first line the level-order, and then in the second line the in-order traversal sequences of the inverted tree. There must be exactly one space between any adjacent numbers, and no extra space at the end of the line.

Sample Input:
8
1 –
– –
0 –
2 7
– –
– –
5 –

Sample Output:
3 7 2 6 4 0 5 1
6 5 7 4 3 2 0 1

题⽬⼤意:反转⼀棵⼆叉树,给出原⼆叉树的每个结点的左右孩⼦,输出它的层序和前序遍历~
分析: 1. 反转⼆叉树就是存储的时候所有左右结点都交换。
2. ⼆叉树使⽤{id, l, r, index, level}存储每个结点的id, 左右结点,下标值,和当前层数~
3. 根结点是所有左右结点中没有出现的那个结点~
4. 已知根结点,⽤递归的⽅法可以把中序遍历的结果push_back到数组v1⾥⾯,直接输出就是中
序,排序输出就是层序(排序⽅式,层数⼩的排前⾯,相同层数时, index⼤的排前⾯)

#include <vector>
#include <algorithm>
using namespace std;
struct node {
	int id, l, r, index, level;
} a[100];
vector<node> v1;
void dfs(int root, int index, int level) {
	if (a[root].r != -1) dfs(a[root].r, index * 2 + 2, level + 1);
	v1.push_back({root, 0, 0, index, level});
	if (a[root].l != -1) dfs(a[root].l, index * 2 + 1, level + 1);
}
bool cmp(node a, node b) {
	if (a.level != b.level) return a.level < b.level;
	return a.index > b.index;
}
int main() {
	int n, have[100] = {0}, root = 0;
	cin >> n;
	for (int i = 0; i < n; i++) {
		a[i].id = i;
		string l, r;
		cin >> l >> r;
		if (l != "-") {
			a[i].l = stoi(l);
			have[stoi(l)] = 1;
		} else {
			a[i].l = -1;
		}
		if (r != "-") {
			a[i].r = stoi(r);
			have[stoi(r)] = 1;
		} else {
			a[i].r = -1;
		}
	}
	while (have[root] == 1) root++;
	dfs(root, 0, 0);
	vector<node> v2(v1);
	sort(v2.begin(), v2.end(), cmp);
	for (int i = 0; i < v2.size(); i++) {
		if (i != 0) cout << " ";
		cout << v2[i].id;
	}
	cout << endl;
	for (int i = 0; i < v1.size(); i++) {
		if (i != 0) cout << " ";
		cout << v1[i].id;
	}
	return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值