Milking Cows

题目描述:

Three farmers rise at 5 am each morning and head for the barn to milk three cows. The first farmer begins milking his cow at time 300 (measured in seconds after 5 am) and ends at time 1000. The second farmer begins at time 700 and ends at time 1200. The third farmer begins at time 1500 and ends at time 2100. The longest continuous time during which at least one farmer was milking a cow was 900 seconds (from 300 to 1200). The longest time no milking was done, between the beginning and the ending of all milking, was 300 seconds (1500 minus 1200).

Your job is to write a program that will examine a list of beginning and ending times for N (1 <= N <= 5000) farmers milking N cows and compute (in seconds):

输入输出格式:

SAMPLE INPUT (file milk2.in)

3
300 1000
700 1200
1500 2100

 

OUTPUT FORMAT

A single line with two integers that represent the longest continuous time of milking and the longest idle time.

SAMPLE OUTPUT (file milk2.out)

900 300

题目大意:

三个农民每天清晨5点起床,然后去牛棚给3头牛挤奶。第一个农民在300时刻(从5点开始计时,秒为单位)给他的牛挤奶,一直到1000时刻。第二个农民在700时刻开始,在 1200时刻结束。第三个农民在1500时刻开始2100时刻结束。期间最长的至少有一个农民在挤奶的连续时间为900秒(从300时刻到1200时刻),而最长的无人挤奶的连续时间(从挤奶开始一直到挤奶结束)为300时刻(从1200时刻到1500时刻)。 你的任务是编一个程序,读入一个有N个农民(1 <= N <= 5000)挤N头牛的工作时间列表,计算以下两点(均以秒为单位): 最长至少有一人在挤奶的时间段。 最长的无人挤奶的时间段。(从有人挤奶开始算起) 

解题思路:

一定要配合代码来看,我使用python来写的解题代码,有问题,在usaco提交会出现5000个数字那个会超时,改成c++版本就不会有问题,c++版本在网上有许多我就不贴了,然后大概看了一下算法复杂度大概在O(nlogn+n),我以为用python不会存在超时问题,但是最后还是超时了,然后我又看了一下运行时间,c++版与python的差距大约是10倍,所以要用python要注意时间问题,大概思路就是要先按时间表进行排序,然后进行合并,看代码,看代码

"""
ID: scwswx2
LANG: PYTHON3
TASK: milk2
"""
fin = open ('test.in', 'r')
fout = open ('test.out', 'w')
sumline=int(fin.readline().strip('\n'))
list=[]
for i in  range(sumline):
    begin,end=map(int,fin.readline().split())
    a={'begin':begin,'end':end}
    list.append(a)
list.sort(key=lambda k:(k.get('begin',0)))#先进行排序
ans=0
for i in range(sumline):#找到最大那段
    left=list[i].get('begin')
    right=list[i].get('end')
    for j in range(i,sumline):
        if list[j].get('begin')>right:
            break
        else:
            right=max(list[j].get('end'),right)
    ans=max(ans,(right-left))
#print(ans)
#找到最小那一段
cnt=0
r=list[0].get('end')
for i in range(sumline):
    if list[i].get('begin')>r:
        cnt=max(cnt,(list[i].get('begin')-r))
    r=max(r,list[i].get('end'))
#print(ans,cnt)
fout.write(str(ans)+' '+str(cnt)+'\n')
fout.close()

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Based on the following story, continue the story by writing two paragraphs, paragraph 1 beginning with "A few weeks later, I went to the farm again. " and paragraph 2 beginning with "I was just about to leave when the hummingbird appeared."respectively with 150 words. I was invited to a cookout on an old friend's farm in western Washington. I parked my car outside the farm and walked past a milking house which had apparently not been used in many years.A noise at a window caught my attention,so I entered it. It was a hummingbird,desperately trying to escape. She was covered in spider-webs and was barely able to move her wings. She ceased her struggle the instant I picked her up. With the bird in my cupped hand, I looked around to see how she had gotten in. The broken window glass was the likely answer. I stuffed a piece of cloth into the hole and took her outside,closing the door securely behind me. When I opened my hand, the bird did not fly away; she sat looking at me with her bright eyes.I removed the sticky spider-webs that covered her head and wings. Still, she made no attempt to fly.Perhaps she had been struggling against the window too long and was too tired? Or too thirsty? As I carried her up the blackberry-lined path toward my car where I kept a water bottle, she began to move. I stopped, and she soon took wing but did not immediately fly away. Hovering,she approached within six inches of my face. For a very long moment,this tiny creature looked into my eyes, turning her head from side to side. Then she flew quickly out of sight. During the cookout, I told my hosts about the hummingbird incident. They promised to fix the window. As I was departing, my friends walked me to my car. I was standing by the car when a hummingbird flew to the center of our group and began hovering. She turned from person to person until she came to me. She again looked directly into my eyes, then let out a squeaking call and was gone. For a moment, all were speechless. Then someone said, “She must have come to say good-bye.”
02-12

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值