Oulipo KMP

题意:T组数据

            第一行是单词,第二行文本,问单词在文本中出现多少次

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

#include<stdio.h>
#include<string.h>
char w[10010];
int pre[10010];
char str[1000010];
int lw;
void predeal(){
     pre[1]=0;
     int j=0;
     for(int i=2;i<=lw;i++)
     {
         while(j>0&&w[j+1]!=w[i]) j=pre[j];
         if(w[j+1]==w[i]) j++;
         pre[i]=j;
     }
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--){
        scanf("%s%s",w+1,str);
        lw=strlen(w+1);
        predeal();
        int len=strlen(str);
        int st=0,j=0;
        int ans=0;
        while(st<len){
            if(w[j+1]==str[st]){
                j++;st++;
                if(j==lw) ans++,j=pre[j];
            }
            else if(j>0) j=pre[j];
            else st++;
        }
        printf("%d\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值