Java基础编程练习

这篇文章讲述了如何在Java类Student中重写Object类的equals方法,确保当两个Student对象的学号(id)相同时被判定为同一个对象。给出了一个测试程序和答案示例,展示了如何在Student50类中实现equals方法覆盖。
摘要由CSDN通过智能技术生成

6-50 重写父类方法equals分数 10

在类Student中重写Object类的equals方法。使Student对象学号(id)相同时判定为同一对象。

函数接口定义:

在类Student中重写Object类的equals方法。使Student对象学号(id)相同时判定为同一对象。

裁判测试程序样例:

import java.util.Scanner;
class Student {
     int id;
     String name;
     int age;
     public Student(int id,     String name,     int age) {
         this.id = id;
         this.name = name;
         this.age = age;
     }
   
     /* 请在这里填写答案 */
   
}
public class Main {
    public static void main(String[] args) {
    Scanner sc = new Scanner(System.in);
        Student s1 = new Student(sc.nextInt(),sc.next(),sc.nextInt());
        Student s2 = new Student(sc.nextInt(),sc.next(),sc.nextInt());
        System.out.println(s1.equals(s2));
        sc.close();
    }
}

输入样例:

1001 Peter 20
1001 Jack 18

输出样例:

true

以下是答案


import java.util.Scanner;
public class Pta_6_50 {
	public static void main(String args[]) {
		Scanner sc = new Scanner(System.in);
		Student50 s1 = new Student50(sc.nextInt(),sc.next(),sc.nextInt());
		Student50 s2 = new Student50(sc.nextInt(),sc.next(),sc.nextInt());
		System.out.println(s1.equals(s2));
		sc.close();
	}
}
//这个包下有Studen了用Student50代替
class Student50{
	int id;
	String name;
	int age;
	public Student50(int id,String name,int age){
		this.id=id;
		this.name=name;
		this.age=age;
	}
	//以下是答案,这里需要覆写equals
	public boolean equals(Object obj){
		if(this==obj) {
			return true;//如果是一个对象,返回true
		}
		if(obj ==null||getClass()!=obj.getClass()) {//如果不是一个类型返回false
			return false;
		}
		Student50 other = (Student50) obj;
		return this.id==other.id;
	}
}
  • 9
    点赞
  • 7
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值