Java基础编程练习

本文介绍了一个Java程序,它通过使用`ScriptEngine`和`ScriptEngineManager`来解析输入的一行表达式,如(2+32)/2-6,并计算其结果,如输出11。
摘要由CSDN通过智能技术生成

7-46 表达式计算分数 10

Write a program that reads an expression in a line as input and prints out the result. Only non-negative integers and operators below are allowed in the expression:

+ - * / % ( )

输入格式:

A line of expression.

输出格式:

The result.

输入样例:

(2+32)/2-6

输出样例:

11

以下是答案


import java.util.Scanner;
import javax.script.ScriptEngine;
import javax.script.ScriptEngineManager;
import javax.script.ScriptException;
//这个方法太高级了
public class Pta_7_46 {
	public static void main(String args[]) {
		Scanner sc = new Scanner(System.in);
		String a = sc.nextLine();
		try {
            ScriptEngineManager manager = new ScriptEngineManager();
            ScriptEngine engine = manager.getEngineByName("js");

            // 使用 eval 方法计算表达式
            Object result = engine.eval(a);

            System.out.println(result);
        } catch (ScriptException e) {
            e.printStackTrace();
        }
	}
}

  • 9
    点赞
  • 10
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值