POJ - 1611 - The Suspects(并查集)

The Suspects

Time Limit: 1000MS             Memory Limit: 20000K
Total Submissions: 26579   Accepted: 12991

Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.

Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.

Output

For each case, output the number of suspects in one line.

Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1


题意:同学们有分组,若每个分组里的任一个同学被怀疑感染了SARS,则认为该组所有的都有被感染的嫌疑,让输出所有怀疑感染SARS的人数

第一次做并查集,百度各种文章看了好久,算是迷迷糊糊懂了一些,还是得多多练习才行


#include<cstdio>
#include<cstring>
#include<algorithm>
#define MAXN 30005
using namespace std;
int uset[MAXN], rank[MAXN];     //rank是树高

int find(int x){       //找父节点
    if(x != uset[x])
        uset[x] = find(uset[x]);
    return uset[x];
}


int main() {
    int n, m, k;
    while(scanf("%d %d", &n, &m) && n+m){
        for(int i = 0; i < n; i++){     //给每个节点和树高初始化
            uset[i] = i;
            rank[i] = 0;
        }
        if(!m){
            printf("1\n");
            continue;
        }

        int a, b, k;
        for(int i = 0; i < m; i++){
            scanf("%d", &k);
            k--;
            scanf("%d", &a);
            while(k--){
                scanf("%d", &b);
                a = find(a);
                b = find(b);
                if(a == b)
                    continue;
                if(rank[a] > rank[b])     //把低的树合并到高的树里面
                    uset[b] = a;
                else{
                    uset[a] = b;
                    if(rank[a] == rank[b])
                        rank[b]++;
                }
                a = b;
            }
        }

        int ans = 0, u = find(0);     //查找和0的根节点相同的人
        for(int i = 0; i < n; i++)
            if(find(i) == u)
                ans++;
        printf("%d\n", ans);
    }
    return 0;
}


相关资料:并查集
觉得写的很不错,对我刚开始学习并查集很有帮助,大家可以参考一下

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值