PAT甲级A1144 The Missing Number(20 分)

1144 The Missing Number(20 分)

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤10​5​​). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:

10
5 -25 9 6 1 3 4 2 5 17

Sample Output:

7

题意:给定一串int型数字,让你找出没在这串数字中出现的最小正整数。

思路:由于数据在int范围内,所以不能直接开hash数组标记存在,定义一个全局序号k(初始=1),然后使用set容器存储数据,由于set可以自动排序和去重,因此把所有正整数存进去后,然后从第一个数字开始读取set中的数字,若 发现当前set中数字和序号k不同则说明k是第一个没有在set中出现的正整数,输出即可,如果整个set全部有序,注意最后特判输出k。

参考代码:

#include<cstdio>
#include<set>
using namespace std;
set<int> st;
int main()
{
	int n,t,k=1;
	scanf("%d",&n);
	for(int i=0;i<n;i++){
		scanf("%d",&t);
		if(t>0)
			st.insert(t);
	}
	bool flag=false;
	for(auto it=st.begin();it!=st.end()&&!flag;it++){
		if(*it!=k) {
			printf("%d\n",k);
			flag=true;
		}
		k++;
	}
	if(!flag) printf("%d\n",k);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值