PAT(A) - 1144. The Missing Number (20)

1144. The Missing Number (20)

时间限制
150 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Given N integers, you are supposed to find the smallest positive integer that is NOT in the given list.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<= 105). Then N integers are given in the next line, separated by spaces. All the numbers are in the range of int.

Output Specification:

Print in a line the smallest positive integer that is missing from the input list.

Sample Input:
10
5 -25 9 6 1 3 4 2 5 17
Sample Output:
7

题意是给你一个序列,让你找一个数x,x是不在这个序列里的最小正整数。

样例解释:其中样例里的正整数是1、2、3、4、5、6、9、17。其中不在这个序列里的最小正整数是7,所以答案是7

思路分析:使用map来保存输入的元素,如果不是正整数就不用保存,然后从输入序列里最小的那个正整数开始,每次+1判断map中是否出现。

需要注意的坑点:可能输入序列里就没有正整数,这时候要输出1。否则你只能得18分

#include <cstdio>
#include <map>

#define INF 0x3fffffff

using namespace std;
map<int, int> mp;
int Min = INF;

int main() {
    int n, v;
    scanf( "%d", &n );
    for( int i = 0; i < n; i++ ) {
        scanf( "%d", &v );
        if( v > 0 ) {
            mp[v] = 1;
            if( v < Min ) Min = v;
        }
    }

    // 如果输入中没有正整数,则输出第一个正整数是1
    if( Min == INF ) {
        printf( "1\n" );
        return 0;
    }

    int ans = Min;
    while( mp.count( ans ) ) ans++;

    printf( "%d\n", ans );

    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值