PAT甲级A1055 The World's Richest (25 分)

Forbes magazine publishes every year its list of billionaires based on the annual ranking of the world's wealthiest people. Now you are supposed to simulate this job, but concentrate only on the people in a certain range of ages. That is, given the net worths of N people, you must find the M richest people in a given range of their ages.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤10​5​​) - the total number of people, and K (≤10​3​​) - the number of queries. Then N lines follow, each contains the name (string of no more than 8 characters without space), age (integer in (0, 200]), and the net worth (integer in [−10​6​​,10​6​​]) of a person. Finally there are K lines of queries, each contains three positive integers: M (≤100) - the maximum number of outputs, and [Amin, Amax] which are the range of ages. All the numbers in a line are separated by a space.

Output Specification:

For each query, first print in a line Case #X: where X is the query number starting from 1. Then output the M richest people with their ages in the range [Amin, Amax]. Each person's information occupies a line, in the format

Name Age Net_Worth

The outputs must be in non-increasing order of the net worths. In case there are equal worths, it must be in non-decreasing order of the ages. If both worths and ages are the same, then the output must be in non-decreasing alphabetical order of the names. It is guaranteed that there is no two persons share all the same of the three pieces of information. In case no one is found, output None.

Sample Input:

12 4
Zoe_Bill 35 2333
Bob_Volk 24 5888
Anny_Cin 95 999999
Williams 30 -22
Cindy 76 76000
Alice 18 88888
Joe_Mike 32 3222
Michael 5 300000
Rosemary 40 5888
Dobby 24 5888
Billy 24 5888
Nobody 5 0
4 15 45
4 30 35
4 5 95
1 45 50

Sample Output:

Case #1:
Alice 18 88888
Billy 24 5888
Bob_Volk 24 5888
Dobby 24 5888
Case #2:
Joe_Mike 32 3222
Zoe_Bill 35 2333
Williams 30 -22
Case #3:
Anny_Cin 95 999999
Michael 5 300000
Alice 18 88888
Cindy 76 76000
Case #4:
None

题意:给定n个人的姓名,年龄,财富净值,让你仿照福布斯排行榜,给特定年龄段的人按财富净值排序输出,如果财富净值相同按年龄升序排列,如果年龄也相同按姓名字母顺序排列,题目保证唯一。 

思路:由于数据量较大,时间限制较少,因此姓名使用字符数组存储,首先对所有人进行一次排序,然后根据问题要求,遍历一次排行榜,把符合年龄要求的人员输出,直到输出人员满足要求或者遍历完成。如果整个遍历过程没有一个符合要求则输出“None”。

参考代码:

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
struct node{
	char name[10];
	int age,Net_Worth;
};
bool cmp(node a,node b){
	if(a.Net_Worth!=b.Net_Worth) return a.Net_Worth>b.Net_Worth;
	else if(a.age!=b.age) return a.age<b.age;
	else return strcmp(a.name,b.name)<0;
}
int main()
{
	int n,k,M,Amin,Amax;
	scanf("%d%d",&n,&k);
	vector<node> v(n);
	for(int i=0;i<n;i++){
		scanf("%s %d %d",&v[i].name,&v[i].age,&v[i].Net_Worth);
	}
	sort(v.begin(),v.end(),cmp);
	for(int i=1;i<=k;i++){
		scanf("%d %d %d",&M,&Amin,&Amax);
		int cnt=0;		//cnt统计实际输出人数
		printf("Case #%d:\n",i);
		for(int j=0;j<v.size()&&M;j++){
			if(v[j].age>=Amin&&v[j].age<=Amax){
				printf("%s %d %d\n",v[j].name,v[j].age,v[j].Net_Worth);
				M--;
				cnt++;
			}
		}
		if(cnt==0) printf("None\n");
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值