PAT甲级A1090 Highest Price in Supply Chain (25 分)

29 篇文章 0 订阅
22 篇文章 0 订阅

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​5​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i​​ is the index of the supplier for the i-th member. S​root​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10​10​​.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

题意:给出一棵树形的商品供应图,一共n个结点,初始价格p,每增加一层价格增速为r%,求最高的商品售价和对应零售店的数量 。

思路:直接建立树形结构,然后使用DFS求最高价格以及对应叶结点数量,注意价格范围需要使用double类型,才不会越界。

参考代码:

#include<cstdio>
#include<vector>
using namespace std;
int n,root,num=0;
double p,r,MaxPrice=0;
struct node{
	vector<int> child;
}T[100010];
void DFS(int u,double price){
	if(T[u].child.size()==0){
		if(price>MaxPrice){
			MaxPrice=price;
			num=1;
		}else if(price==MaxPrice)
			num++;
		return;
	}
	for(int i=0;i<T[u].child.size();i++){
		int v=T[u].child[i];
		DFS(v,(1+r/100)*price);
	}
}

int main()
{
	int t;
	scanf("%d%lf%lf",&n,&p,&r);
	for(int i=0;i<n;i++){
		scanf("%d",&t);
		if(t==-1) {
			root=i;
			continue;
		}
		T[t].child.push_back(i);
	}
	DFS(root,p);
	printf("%.2f %d\n",MaxPrice,num);
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值