PAT-A1090 Highest Price in Supply Chain 题目内容及题解

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one's supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (≤10​^5​​), the total number of the members in the supply chain (and hence they are numbered from 0 to N−1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number S​i​​ is the index of the supplier for the i-th member. S​root​​ for the root supplier is defined to be −1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 10^​10​​.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

题目大意

题目给定一个供应链信息,要求输出整个供应链中零售商可出售的最高价格和以最高价格出售产品的供应商数量。

解题思路

  1. 读入数据并存储每个结点的孩子结点信息;
  2. 通过DFS找到最深的节点层数并返回最深层数的节点数量;
  3. 计算并按照题目要求输出结果;
  4. 返回零值。

代码

#include<cstdio>
#include<vector>
#include<cmath>
using namespace std;
#define maxn 100010

double P,r;
int N,root;
vector<int> children[maxn];

int maxdepth,count;

void Init(){
    int i,a;
    scanf("%d%lf%lf",&N,&P,&r);
    r=r/100.0+1.0;
    for(i=0;i<N;i++){
        scanf("%d",&a);
        if(a<0){
            root=i;
        }else{
            children[a].push_back(i);
        }
    }
    maxdepth=-1;
}

void DFS(int r,int depth){
    int i;
    if(depth>maxdepth){
        maxdepth=depth;
        count=1;
    }else if(depth==maxdepth){
        count++;
    }
    for(i=0;i<children[r].size();i++){
        DFS(children[r][i],depth+1);
    } 
}

int main(){
    Init();
    DFS(root,0);
    r=pow(r,maxdepth);
    printf("%.2f %d\n",P*r,count);
    return 0; 
} 

运行结果

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值