PAT甲级A1122 Hamiltonian Cycle (25 分)

18 篇文章 0 订阅

The "Hamilton cycle problem" is to find a simple cycle that contains every vertex in a graph. Such a cycle is called a "Hamiltonian cycle".

In this problem, you are supposed to tell if a given cycle is a Hamiltonian cycle.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers N (2<N≤200), the number of vertices, and M, the number of edges in an undirected graph. Then M lines follow, each describes an edge in the format Vertex1 Vertex2, where the vertices are numbered from 1 to N. The next line gives a positive integer K which is the number of queries, followed by K lines of queries, each in the format:

n V​1​​ V​2​​ ... V​n​​

where n is the number of vertices in the list, and V​i​​'s are the vertices on a path.

Output Specification:

For each query, print in a line YES if the path does form a Hamiltonian cycle, or NO if not.

Sample Input:

6 10
6 2
3 4
1 5
2 5
3 1
4 1
1 6
6 3
1 2
4 5
6
7 5 1 4 3 6 2 5
6 5 1 4 3 6 2
9 6 2 1 6 3 4 5 2 6
4 1 2 5 1
7 6 1 3 4 5 2 6
7 6 1 2 5 4 3 1

Sample Output:

YES
NO
NO
NO
YES
NO

题意:给出一个无向图,再给你q条路径,问你这些路径是否是简单圈。简单圈的定义是:要遍历图中所有顶点,且除了首尾顶点外,不能有重复顶点。

思路:根据简单圈的定义,判断给定的路径是否满足:联通,首尾相等,顶点总数等于图中顶点数+1,访问到了图中所有顶点这四个条件。 

参考代码:

#include<cstdio>
#include<cstring>
using namespace std;
int G[210][210],vis[210],n,m,q;	//a存放给出的顶点序列
int main()
{
	int u,v,num,st;
	scanf("%d%d",&n,&m);
	for(int i=0;i<m;i++){
		scanf("%d%d",&u,&v);
		G[u][v]=G[v][u]=1;
	}
	scanf("%d",&q);
	for(int i=0;i<q;i++){
		bool tag=true;
		scanf("%d%d",&num,&st);
		memset(vis,0,sizeof(vis));
		u=st;
		for(int j=1;j<num;j++){
			scanf("%d",&v);
			if(G[u][v]!=1) tag=false;	//判断连通性
			vis[v]=1;
			u=v;
		}
		if(num!=n+1||st!=u) tag=false;
		for(int j=1;j<=n;j++)	//判断是否遍历了全部顶点
			if(vis[j]!=1) tag=false;
		if(tag) printf("YES\n");
		else printf("NO\n");
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值