PAT甲级A1124 Raffle for Weibo Followers (20 分)

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽奖) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (≤ 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print Keep going... instead.

Sample Input 1:

9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain

Sample Output 1:

PickMe
Imgonnawin!
TryAgainAgain

Sample Input 2:

2 3 5
Imgonnawin!
PickMe

Sample Output 2:

Keep going...

题意:给出一串微博转发名单,让你找出其中获奖的id,从给定的位置s开始,每隔n个id抽取一名获奖,如果有重复转发的,则顺次去下一次获奖。

思路:首先把所有昵称读入到字符串数组中,然后从给定的位置开始输出获奖id,为了去重可以使用map来做哈希操作。

参考代码:

#include<cstdio>
#include<string>
#include<iostream>
#include<unordered_map>
using namespace std;
int m,n,s,idx=1;
unordered_map<string,int> mp;
string  ans[1010];
int main()
{
	scanf("%d%d%d",&m,&n,&s);
	for(int i=1;i<=m;i++)
		cin>>ans[i];
	idx=s;
	while(idx<=m){
		while(idx<=m&&mp.count(ans[idx])==1) idx++;
		mp[ans[idx]]=1;
		cout<<ans[idx]<<endl;
		idx+=n;
	}
	if(mp.size()==0) cout<<"Keep going..."<<endl;
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值