PAT advanced level 1001

Calculate a+b and output the sum in standard format – that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:
Each input file contains one test case. Each case contains a pair of integers a and b where −10^6
​​ ≤a,b≤10^6. The numbers are separated by a space.

Output Specification:
For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:
-1000000 9
Sample Output:
-999,991

#include<iostream>
#include<string>
#include<math.h> 
using namespace std;
int main(){
    int a,b,c;
    cin>>a>>b;
    c=a+b;
    int t;
    t=c/1000;
    string s,s1;
    if(abs(c%1000)>=100){
            s=",";
        }
        else if(abs(c%1000)>=10){
            s=",0";
        }
        else{
            s=",00";
        }
        if(abs(t%1000)>=100){
            s1=",";
        }
        else if(abs(t%1000)>=10){
            s1=",0";
        }
        else{
            s1=",00";
        }
    if(c==0){
        cout<<c;
    }
    else if(t==0){
        cout<<c;
    }
    else if(t/1000==0){
        cout<<t<<s<<abs(c%1000);
    }
    else{
        cout<<t/1000<<s1<<abs(t%1000)<<s1<<abs(c%1000000)%1000;
    }
}

以上是我写的代码,因为不知道用简便的方法在C++中把int型转换成string型,所以用了这种办法,但写到后面发现这种办法巨麻烦,而且调整了之后还有一个测试点没有通过。
在这里插入图片描述
不明白是什么原因,明天再找找相关办法。
试试int转化为string或者换种语言来写。

2/16更新
暂时不知道自己漏了哪一个点,所以换了一种办法来解

#include <iostream>
#include<math.h>
using namespace std;
int main()
{
	int a,b,n,ans;
    cin>>a>>b;
    n=a+b;
    ans=0;
    char str[10];//弄个数组存下输出的数
    int k=0;
    if(n==0){  //后来发现漏了一个0的情况
        cout<<n;
    }
    else{
        while(abs(n)>0){
    	ans++; //用ans记录现在正在存的位数
		if(abs(n)/10==0){
			cout<<n; //到首位时可以直接输出
			break;
		}
		str[k]=abs(n%10)+48;  //才发现-991%10=-1  
		k++;
		if(ans%3==0){
    		str[k]=',';
    		k++;
		}
		n/=10;
	}
	for(int i=k-1;i>=0;i--){
		cout<<str[i]; 
	}
    }
}

在这里插入图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值