PAT (Advanced Level)1001 A+B Format (20分)

Calculate a+b and output the sum in standard format -- that is, the digits must be separated into groups of three by commas (unless there are less than four digits).

Input Specification:

Each input file contains one test case. Each case contains a pair of integers a and b where −10​6​​≤a,b≤10​6​​. The numbers are separated by a space.

Output Specification:

For each test case, you should output the sum of a and b in one line. The sum must be written in the standard format.

Sample Input:

-1000000 9

Sample Output:

-999,991

 

#include<stdio.h>

int main(){
	int a,b,sum,i=0,t;
	int array[3]={0};
	scanf("%d %d",&a,&b);
	sum=a+b;
	if(sum<0){					//有负号单独处理 
		sum=-sum;
		printf("-");
	}
	if(sum==0) printf("0");		//结果是0单独处理 
	while(sum!=0){				//把每一段存入数组里 
		array[i++]=sum%1000;
		sum/=1000;
	}
	t=--i;
	while(i!=-1){
		if(t!=i){				//如果不是第一段,就要考虑不是3位数的情况 
			if(array[i]/10==0) printf("00");		//一位数加两个0 
			else if(array[i]/100==0) printf("0");	//两位数加一个0 
			printf("%d",array[i]);	//打印该段数据 
		}else printf("%d",array[i]);	//如果是第一段直接打印出来就好 
		if(i--!=0) printf(",");		//如果后面还有数据,就要加逗号 
	}
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值