Silver Cow Party


    One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

    Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow's return route might be different from her original route to the party since roads are one-way.

    Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input
    Line 1: Three space-separated integers, respectively: N, M, and X
    Lines 2.. M+1: Line i+1 describes road i with three space-separated integers: Ai, Bi, and Ti. The described road runs from farm Ai to farm Bi, requiring Ti time units to traverse. 

Output
    Line 1: One integer: the maximum of time any one cow must walk. 

Sample Input

    4 8 2
    1 2 4
    1 3 2
    1 4 7
    2 1 1
    2 3 5
    3 1 2
    3 4 4
    4 2 3

Sample Output

    10

Hint
    Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units. 


这个题关键是能想到把边的两边互换,其他到是基础的最短路径,用spfa很好写。

代码:

#include<stdio.h>
#include<iostream>
#include<queue>
#include<cstring>
#include<cmath>
#include<vector>

#define INF 0x3f3f3f3f

using namespace std;

int N,M,X;
int data[1005][1005];
int come[1005];
int back[1005];
bool book[1005];

void SpfaB(){
	queue<int>Q;
	Q.push(X);
	book[X] = true;
	while(!Q.empty()){
		int mid = Q.front();
		Q.pop();
		book[mid] = false;
		for(int i=1; i<=N ; i++){
			if(back[mid]+data[mid][i]<back[i]){
				back[i] = back[mid]+data[mid][i];
				if(!book[i]){
					Q.push(i);
					book[i] = true;
				}
			}
		}
	}
}

void SpfaC(){
	queue<int>Q;
	Q.push(X);
	book[X] = true;
	while(!Q.empty()){
		int mid = Q.front();
		Q.pop();
		book[mid] = false;
		for(int i=1; i<=N ; i++){
			if(come[mid]+data[i][mid]<come[i]){
				come[i] = come[mid]+data[i][mid];
				if(!book[i]){
					Q.push(i);
					book[i] = true;
				}
			}
		}
	}
}

int main(){
	scanf("%d %d %d",&N,&M,&X);
	memset(data,INF,sizeof(data));
	for(int i=0 ; i<1005 ; i++){
		data[i][i] = 0;
	}
	for(int i=1 ; i<=M ; i++){
		int a,b,c;
		scanf("%d %d %d",&a,&b,&c);
		data[a][b] = c;
	}
	memset(come,INF,sizeof(come));
	come[X] = 0;
	memset(back,INF,sizeof(back));
	back[X] = 0;
	SpfaB();
	SpfaC();
	int max = 0;
	for(int i=1; i<=N ; i++){
		int mid = come[i]+back[i];
		if(mid>max)max = mid;
	}
	printf("%d\n",max);
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值