Seek the Name, Seek the Fame

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.
Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

题意:
给出一个字符串s,求出s中存在多少子串是公共前后缀。从小到大依次输出这些子串的长度。

思路:
这里写图片描述
如图得到字符串的长度len然后求出len处的Next值并递归的向下求出所有的Next值,得到的就是答案。

代码:

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

#define MAXN 400005

int Next[MAXN];
char s[MAXN];

void getNext()
{
    int i = -1;
    int j = 0;
    Next[0] = -1;
    int len = strlen(s);
    while(j<len)
    {
        if(i == -1 || s[j] == s[i])Next[++j] = ++i;
        else
        {
            i = Next[i];
        }
    }
}

int re[MAXN];
int temp;

int main()
{
    while(scanf("%s",s)!=EOF)
    {
        getNext();
        int len = strlen(s);
        int mid = Next[len];
        while(mid > 0)
        {
            re[++temp] = mid;
            mid = Next[mid];
        }
        while(temp)
        {
            printf("%d ",re[temp--]);
        }
        printf("%d\n",len);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值