POJ - 3281 Dining (最大流)

Cows are such finicky eaters. Each cow has a preference for certain foods and drinks, and she will consume no others.

Farmer John has cooked fabulous meals for his cows, but he forgot to check his menu against their preferences. Although he might not be able to stuff everybody, he wants to give a complete meal of both food and drink to as many cows as possible.

Farmer John has cooked F (1 ≤ F ≤ 100) types of foods and prepared D (1 ≤ D ≤ 100) types of drinks. Each of his N (1 ≤ N ≤ 100) cows has decided whether she is willing to eat a particular food or drink a particular drink. Farmer John must assign a food type and a drink type to each cow to maximize the number of cows who get both.

Each dish or drink can only be consumed by one cow (i.e., once food type 2 is assigned to a cow, no other cow can be assigned food type 2).

Input
Line 1: Three space-separated integers: N, F, and D
Lines 2.. N+1: Each line i starts with a two integers Fi and Di, the number of dishes that cow i likes and the number of drinks that cow i likes. The next Fi integers denote the dishes that cow i will eat, and the Di integers following that denote the drinks that cow i will drink.

Output
Line 1: A single integer that is the maximum number of cows that can be fed both food and drink that conform to their wishes
Sample Input
4 3 3
2 2 1 2 3 1
2 2 2 3 1 2
2 2 1 3 1 2
2 1 1 3 3
Sample Output
3
Hint
One way to satisfy three cows is:
Cow 1: no meal
Cow 2: Food #2, Drink #2
Cow 3: Food #1, Drink #1
Cow 4: Food #3, Drink #3
The pigeon-hole principle tells us we can do no better since there are only three kinds of food or drink. Other test data sets are more challenging, of course.

题解:

拆点(cow,cow`),建立超级源点和超级汇点,超级源点连接所有的food,food连接cow,cow连接cow`,cow`连接drink,所有drink又连接超级汇点。然后就是基础的DINIC跑一遍。

代码:

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>

using namespace std;

const int INF = 0x3f3f3f3f;
const int MAXN = 410;//F:100 + D:100 + N:100*2

struct Edge{
	int to,value,rev;
	Edge(){}
	Edge(int a,int b,int c):to(a),value(b),rev(c){}
};

vector<Edge> E[MAXN];

inline void Add(int from,int to,int value){
	E[from].push_back(Edge(to,value,E[to].size()));
	E[to].push_back(Edge(from,0,E[from].size()-1));
}

int deep[MAXN];
int iter[MAXN];

bool BFS(int from,int to){
	memset(deep,-1,sizeof deep);
	deep[from] = 0;
	queue<int> Q;
	Q.push(from);
	while(!Q.empty()){
		int t = Q.front();
		Q.pop();
		for(int i=0 ; i<E[t].size() ; ++i){
			Edge& e = E[t][i];
			if(e.value > 0 && deep[e.to] == -1){
				deep[e.to] = deep[t] + 1;
				Q.push(e.to);
			}
		}
	}
	return deep[to] != -1;
}

int DFS(int from,int to,int flow){
	if(from == to || flow == 0)return flow;
	
	for(int& i=iter[from] ; i<E[from].size() ; ++i){
		Edge& e = E[from][i];
		if(e.value > 0 && deep[e.to] == deep[from]+1){
			int nowflow = DFS(e.to,to,min(flow,e.value));
			if(nowflow > 0){
				e.value -= nowflow;
				E[e.to][e.rev].value += nowflow;
				return nowflow;
			}
		}
	}
	return 0;
}


int Dinic(int from,int to){
	int sumflow = 0;
	while(BFS(from,to)){
		memset(iter,0,sizeof iter);
		int mid;
		while((mid=DFS(from,to,INF)) > 0)sumflow += mid;
	}
	return sumflow;
}

int main(){
	
	int N,F,D;
	int Fi,Di;
	while(scanf("%d %d %d",&N,&F,&D)!=EOF){
		//固定超级源点为0,超级汇点为MAXN-1 
		for(int i=1 ; i<=F ; i++)Add(0,i+200,1); 
		for(int i=1 ; i<=D ; i++)Add(i+300,MAXN-1,1);
		for(int _=1 ; _<=N ; ++_){
			scanf("%d %d",&Fi,&Di);
			Add(_,_+100,1);//拆点 
			for(int i=0 ; i<Fi ; ++i){
				int t;
				scanf("%d",&t);
				Add(t+200,_,1);
			}
			for(int i=0 ; i<Di ; ++i){
				int t;
				scanf("%d",&t);
				Add(_+100,t+300,1);
			}
		}
		printf("%d\n",Dinic(0,MAXN-1));
		for(int i=0 ; i<MAXN ; ++i)E[i].clear();
	}
	
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值