pat 甲级 1003 Emergency (求最短路径条数)

As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:

Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C​1​​ and C​2​​ - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c​1​​, c​2​​ and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1​​ to C​2​​.

Output Specification:

For each test case, print in one line two numbers: the number of different shortest paths between C​1​​ and C​2​​, and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

题解:基础双权值最短路再加一个数组记录最短路条数就行了,注意点主要是两种情况下最短路条数的改变关系。

代码:

#include <bits/stdc++.h>

using namespace std;

const int MAXN = 505;
const int INF = 0x3f3f3f3f;

struct Edge{
	int len;
	int to;
	int next;
}E[MAXN*MAXN*2];

struct Node{
	int spot;
	int len;
	Node(int a,int b):spot(a),len(b){}
};

struct cmp{
	bool operator()(Node a,Node b){
		if(a.len == b.len)return a.spot > b.spot;
		return a.len > b.len;
	}
};

int tot;
int head[MAXN];
bool book[MAXN];
int hands[MAXN];//存每个城市的救援队个数 
int hand[MAXN];//存到达每个城市最多可集结多少救援队 
int length[MAXN];
int num[MAXN];//存到每个城市的最短路径个数 

void Add(int _from,int _to,int _len){
	E[++tot].next = head[_from];
	E[tot].to = _to;
	E[tot].len = _len;
	head[_from] = tot;
	E[++tot].next = head[_to];
	E[tot].to = _from;
	E[tot].len = _len;
	head[_to] = tot;
}

void Dijkstra(int S){
	memset(book,false,sizeof book);
	memset(length,INF,sizeof length);
	memset(hand,0,sizeof hand);
	memset(num,0,sizeof num);
	priority_queue<Node,vector<Node>,cmp> Q;
	length[S] = 0;
	num[S] = 1;
	hand[S] = hands[S];
	Q.push(Node(S,0));
	while(!Q.empty()){
		Node now = Q.top();
		Q.pop();
		if(book[now.spot])continue;
		book[now.spot] = true;
		for(int i=head[now.spot] ; i ; i=E[i].next){
			int to = E[i].to;
			if(length[to] > length[now.spot] + E[i].len){
				length[to] = length[now.spot] + E[i].len;
				hand[to] = hand[now.spot] + hands[to];
				num[to] = num[now.spot];//注意点1 
				Q.push(Node(to,length[to]));
			}
			else if(length[to] == length[now.spot] + E[i].len){
				num[to] += num[now.spot];//注意点2 
				if(hand[to] < hand[now.spot] + hands[to]){
					hand[to] = hand[now.spot] + hands[to];
					Q.push(Node(to,length[to]));
				}
			}
		}
	}
}

int main(){
	
	int N,M,S,T;
	while(scanf("%d %d %d %d",&N,&M,&S,&T) == 4){
		memset(head,0,sizeof head);
		tot = 0;
		int from,to,len;
		for(int i=0 ; i<N ; ++i)scanf("%d",&hands[i]);
		for(int i=0 ; i<M ; ++i){
			scanf("%d %d %d",&from,&to,&len);
			Add(from,to,len);
		}
		Dijkstra(S);
		printf("%d %d\n",num[T],hand[T]);
	}
	
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值