HDU1789 贪心

Doing Homework again

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 14162    Accepted Submission(s): 8216


Problem Description
Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.
 

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
 

Output
For each test case, you should output the smallest total reduced score, one line per test case.
 

Sample Input
  
  
3 3 3 3 3 10 5 1 3 1 3 1 6 2 3 7 1 4 6 4 2 4 3 3 2 1 7 6 5 4
 

Sample Output
  
  
0 3 5
 

以作业的分值为第一关键字,作业的最后期限为第二关键字排序。从后往前安排时间,将时间期限用一个数组来标记,如果遍历到最前面都没有把作业安排进去,就说明作这份作业不划算。

#include <iostream>
#include <algorithm>
#include <cstring>
using namespace std;
typedef pair<int, int> P;

bool cmp(const P a, const P b){
    if(a.second == b.second)
        return a.first < b.first;
    return a.second > b.second;
}

int main(){
    cin.tie(0);
    cout.tie(0);
    P p[1007];
    bool flg[1007];
    int T;
    cin >> T;
    while(T--){
        memset(flg, 0, sizeof(flg));
        int n;
        cin >> n;
        for(int i = 0; i < n; i++)
            cin >> p[i].first;
        for(int i = 0; i < n; i++)
            cin >> p[i].second;
        sort(p, p + n, cmp);
        int ans = 0;
        for(int i = 0; i < n; i++){
            int j;
            for(j = p[i].first - 1; j >= 0; j--)
                if(!flg[j]){
                    flg[j] = true;
                    break;
                }
            if(j == -1)
                ans += p[i].second;
        }
        cout << ans << endl;
    }
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值