uva10050

题目:
A social research organization has determined a simple set of parameters to simulate the behavior of
the political parties of our country. One of the parameters is a positive integer h (called the hartal
parameter) that denotes the average number of days between two successive hartals (strikes) called by
the corresponding party. Though the parameter is far too simple to be flawless, it can still be used to
forecast the damages caused by hartals. The following example will give you a clear idea:
Consider three political parties. Assume h1 = 3, h2 = 4 and h3 = 8 where hi
is the hartal parameter
for party i (i = 1, 2, 3). Now, we will simulate the behavior of these three parties for N = 14 days.
One must always start the simulation on a Sunday and assume that there will be no hartals on weekly
holidays (on Fridays and Saturdays).
1 2 3 4 5 6 7 8 9 10 11 12 13 14
Days
Su Mo Tu We Th Fr Sa Su Mo Tu We Th Fr Sa
Party 1 x x x x
Party 2 x x x
Party 3 x
Hartals 1 2 3 4 5
The simulation above shows that there will be exactly 5 hartals (on days 3, 4, 8, 9 and 12) in 14
days. There will be no hartal on day 6 since it is a Friday. Hence we lose 5 working days in 2 weeks.
In this problem, given the hartal parameters for several political parties and the value of N, your
job is to determine the number of working days we lose in those N days.
Input
The first line of the input consists of a single integer T giving the number of test cases to follow.
The first line of each test case contains an integer N (7 ≤ N ≤ 3650) giving the number of days over
which the simulation must be run. The next line contains another integer P (1 ≤ P ≤ 100) representing
the number of political parties in this case. The ith of the next P lines contains a positive integer hi
(which will never be a multiple of 7) giving the hartal parameter for party i (1 ≤ i ≤ P).
Output
For each test case in the input output the number of working days we lose. Each output must be on a
separate line.
Sample Input
2
14
3
3
4
8
100
4
12
15
25
40
Sample Output
5
15

题目大意:
计算出由于罢工有几个工作日被冲掉。

思路:
在days中,有罢工的日子就在队列数组中插入‘x’,这样就可以判断在不同的party中某一天是否有罢工,然后加入在第i天 i的队列中有元素,且(i%7)!=0 且 (i+1)%7!=0 即不是周五或者周六 那么就将count++;
代码:

#include <iostream>
using namespace std;
#include <queue>

queue<char> day[3655];

int main()
{
    int n;
    int i;
    int h;
    int days,partyN;
    int count = 0;
    cin >> n;
    while (n--)
    {
        count = 0;
        cin >> days;
        cin >> partyN;
        while (partyN--)
        {
            cin >> h;
            for (i = 1; i <= days; i++)
            {
                if (i%h == 0)
                    day[i].push('x');
            }
        }
        for (i = 1; i <=days ; i++)
        {
            if (!day[i].empty() && (i%7)!=0 && (i+1)%7!=0)
                count++;
            while (!day[i].empty())
                day[i].pop();
        }
        printf("%d\n", count);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值