Red and Black

        There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0
Sample Output
45
59
6
13
题意:给出n*m矩阵,有红格与黑格,不能走红格,只能走黑格,要求输出从一个起始点出发能够踩到的黑色格子数
题解:从起点开始深度搜索,搜过的标记不再访问,记录搜过的数量,输出遍历的次数
#include<iostream> 
#include<algorithm>
using namespace std;
int w;
int h; 
char path[35][35];
int dfs(int x,int y){
	if(path[x][y]=='#'||x<0||y<0||x>=w||y>=h)
		return 0;
	else{
		path[x][y]='#';
		//这条路可以走,先+1,再打算往四个方向走 
		return 1+dfs(x-1,y)+dfs(x+1,y)+dfs(x,y-1)+dfs(x,y+1);
	}
}
int main(){
	int x;
	int y;
	while((cin>>h>>w),(w||h)){
		for(int i=0;i<w;i++)
			for(int j=0;j<h;j++){
				cin>>path[i][j];
				if(path[i][j]=='@'){
					x=i;
					y=j;
				}
			}
		cout<<dfs(x,y)<<endl;	
	}
	return 0;
}
 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值