Hopscotch

        The cows play the child's game of hopscotch in a non-traditional way. Instead of a linear set of numbered boxes into which to hop, the cows create a 5x5 rectilinear grid of digits parallel to the x and y axes.

They then adroitly hop onto any digit in the grid and hop forward, backward, right, or left (never diagonally) to another digit in the grid. They hop again (same rules) to a digit (potentially a digit already visited).

With a total of five intra-grid hops, their hops create a six-digit integer (which might have leading zeroes like 000201).

Determine the count of the number of distinct integers that can be created in this manner.
Input
* Lines 1..5: The grid, five integers per line
Output
* Line 1: The number of distinct integers that can be constructed
Sample Input
1 1 1 1 1
1 1 1 1 1
1 1 1 1 1
1 1 1 2 1
1 1 1 1 1
Sample Output
15
Hint
OUTPUT DETAILS:

111111, 111112, 111121, 111211, 111212, 112111, 112121, 121111, 121112, 121211, 121212, 211111, 211121, 212111, and 212121 can be constructed. No other values are possible.       

题意:在5*5的格子里,现在可以从任意点出发,上下左右移动,可以重复走过的点,每次只能走6步。问经过的格子中组成的6位数有多少种?

题解:遍历图中的每一个位置,然后从该位置开始暴力搜索,判断这个6位数之前出没出现过,记录走的步数,步数超过6步就停止

#include<iostream>
#include<algorithm>
#include<string.h>
using namespace std;
int path[6][6];
int ans;
bool vis[10000005];
int dir_e[4][2]={{-1,0},{1,0},{0,-1},{0,1}};  
void dfs(int x,int y,int keep,int n){
	if(keep==6){
		if(!vis[n]){
			vis[n]=1;
			ans++;
		}
		return;
	}
	for(int i=0;i<4;i++){
		int sx=x+dir_e[i][0];
		int sy=y+dir_e[i][1];
		if(sx>=0&&sy>=0&&sx<5&&sy<5)
			dfs(sx,sy,keep+1,n*10+path[sx][sy]);
	}
}
int main(){
	for(int i=0;i<5;i++)
		for(int j=0;j<5;j++)
			cin>>path[i][j];
	ans=0;
	memset(vis,0,sizeof(vis));
	for(int i=0;i<5;i++)
		for(int j=0;j<5;j++)
			dfs(i,j,0,path[0][0]);
	dfs(0,0,0,path[0][0]); 
	cout<<ans<<endl;
	return 0;
} 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值