数据结构上机测试4.1:二叉树的遍历与应用1

数据结构上机测试4.1:二叉树的遍历与应用1

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
输入二叉树的先序遍历序列和中序遍历序列,输出该二叉树的后序遍历序列。
Input
第一行输入二叉树的先序遍历序列;
第二行输入二叉树的中序遍历序列。
Output
输出该二叉树的后序遍历序列。
Example Input
ABDCEF
BDAECF
Example Output
DBEFCA
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct bittree
{
    char data;
    struct bittree * l,* r;
};
struct bittree * create(int len,char * st1,char * st2)
{
    struct bittree * root;
    int i;
    if(len==0)
    {
        return NULL;
    }
    root=(struct bittree *)malloc(sizeof(struct bittree));
    root->data=st1[0];
    for(i=0;i<len;i++)
    {
        if(root->data==st2[i])
        {
            break;
        }
    }
    root->l=create(i,st1+1,st2);
    root->r=create(len-i-1,st1+i+1,st2+i+1);
    return root;

}
void houxu(struct bittree * p)
{
    if(p!=NULL)
    {
        houxu(p->l);
        houxu(p->r);
        printf("%c",p->data);
    }
}
int main()
{
    int len;
    char st1[99],st2[99];
    struct bittree * root;
    scanf("%s %s",st1,st2);
    len=strlen(st1);
    root=create(len,st1,st2);
    houxu(root);
    printf("\n");
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值