数据结构实验之二叉树八:(中序后序)求二叉树的深度

这个题使用前面两个题拼出来的,滑稽.jpg

数据结构实验之二叉树八:(中序后序)求二叉树的深度

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

已知一颗二叉树的中序遍历序列和后序遍历序列,求二叉树的深度。

Input

输入数据有多组,输入T,代表有T组数据。每组数据包括两个长度小于50的字符串,第一个字符串表示二叉树的中序遍历,第二个表示二叉树的后序遍历。

Output

输出二叉树的深度。

Example Input
2
dbgeafc
dgebfca
lnixu
linux
Example Output
4
3
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
struct bittree
{
    char data;
    struct bittree * l,* r;
};
struct bittree * create(int len,char * st1,char * st2)
{
    struct bittree * root;
    int i;
    if(len==0)
    {
        return NULL;
    }
    root=(struct bittree *)malloc(sizeof(struct bittree));
    root->data=st1[len-1];
    for(i=0;i<len;i++)
    {
        if(root->data==st2[i])
        {
            break;
        }

    }
    root->l=create(i,st1,st2);
    root->r=create(len-i-1,st1+i,st2+i+1);
    return root;
}
int houxu(struct bittree * p,int num)
{
    if(p!=NULL)
    {
        num++;
        if(houxu(p->l,num)>houxu(p->r,num))
        {
            return houxu(p->l,num);
        }
        else
        {
            return houxu(p->r,num);
        }

    }
    else
    {
        return num;
    }
}
int main()
{
    int len,n,i,num;
    char st1[99],st2[99];
    struct bittree * root;
    scanf("%d",&n);
    for(i=0;i<=n-1;i++)
    {
        num=0;
        scanf("%s %s",st2,st1);
        len=strlen(st1);
        root=create(len,st1,st2);
        num=houxu(root,num);
        printf("%d\n",num);
    }
    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值