二叉排序树

二叉排序树

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description

二叉排序树的定义是:或者是一棵空树,或者是具有下列性质的二叉树: 若它的左子树不空,则左子树上所有结点的值均小于它的根结点的值; 若它的右子树不空,则右子树上所有结点的值均大于它的根结点的值; 它的左、右子树也分别为二叉排序树。 今天我们要判断两序列是否为同一二叉排序树

Input
开始一个数n,(1<=n<=20) 表示有n个需要判断,n= 0 的时候输入结束。
接下去一行是一个序列,序列长度小于10,包含(0~9)的数字,没有重复数字,根据这个序列可以构造出一颗二叉排序树。
接下去的n行有n个序列,每个序列格式跟第一个序列一样,请判断这两个序列是否能组成同一颗二叉排序树。(数据保证不会有空树)
Output
 
Example Input
2
123456789
987654321
432156789
0
Example Output
NO
NO
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int n,j;
struct bittree
{
    char data;
    struct bittree * ltree,* rtree;
};
struct bittree * create(struct bittree * root ,char x)
{
    if(root==NULL)
    {
        root=(struct bittree *)malloc(sizeof(struct bittree));
        root->data=x;
        root->ltree=NULL;
        root->rtree=NULL;
    }
    else
    {
        if(x>root->data)
        {
            root->rtree=create(root-> rtree,x);
        }
        else
        {
            root->ltree=create(root->ltree,x);
        }
    }
    return root;
}
void qianxu(struct bittree * root,char * b)
{
    if(root!=NULL)
    {
        b[j++]=root->data;
        qianxu(root->ltree,b);
        qianxu(root->rtree,b);
    }
    else
    {
        b[j++]=',';
    }
}
int main()
{
    int k,i,N,I;
    char a[50],b[50],c[50];
    while(scanf("%d",&N) && N != 0)
    {
        scanf("%s",a);
        i=0;j=0;
        n=strlen(a);
        struct bittree * root;
        root=NULL;
        for(k=0;k<n;k++)
        {
            root=create(root,a[i++]);
        }
        qianxu(root,b);
        b[j] = '\0';
        for(I=0;I<=N-1;I++)
        {
            scanf("%s",a);
            i=0;j=0;
            n=strlen(a);
            root=NULL;
            for(k=0;k<=n-1;k++)
            {
                root=create(root,a[i++]);
            }
            qianxu(root,c);
            c[j] = '\0';
            if(strcmp(b,c)==0)
            {
                printf("YES\n");
            }
            else
            {
                printf("NO\n");
            }
        }
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值