数据结构实验之排序八:快速排序

数据结构实验之排序八:快速排序

Time Limit: 1000MS Memory Limit: 65536KB
Problem Description
给定N(N≤10^5)个整数,要求用快速排序对数据进行升序排列,注意不得使用STL。
 
Input
 连续输入多组数据,每组输入数据第一行给出正整数N(≤10^5),随后给出N个整数,数字间以空格分隔。
Output
 输出排序后的结果,数字间以一个空格间隔,行末不得有多余空格。
Example Input
8
49 38 65 97 76 13 27 49
Example Output
13 27 38 49 49 65 76 97
#include <stdio.h>
#include <stdlib.h>
int N,a[1000009];
void shiftdown(int i)
{
    int t,x;
    t=i;
    while(2*i+1<=N-1)
    {
        if(a[i]<a[i*2+1])
        {
            t=i*2+1;
        }
        if(a[t]<a[i*2+2]&&(i*2+2)<=N-1)
        {
            t=i*2+2;
        }
        if(i!=t){x=a[t];a[t]=a[i];a[i]=x;i=t;}
        else break;
    }
}
void sort()
{
    int x;
    while(N)
    {
        x=a[0];
        a[0]=a[N-1];
        a[N-1]=x;
        N--;
        shiftdown(0);
    }
}
int main()
{
    int i,n;
    while(scanf("%d",&N)!=EOF)
    {
        n=N;
        scanf("%d",&a[0]);
        for(i=1;i<=N-1;i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=(N/2)-1;i>=0;i--)
        {
            shiftdown(i);
        }
        sort();
        for(i=0;i<=n-1;i++)
        {
            if(i!=n-1)
            printf("%d ",a[i]);
            else
            printf("%d\n",a[i]);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值