Tram

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch. 

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually. 

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B. 

Input

The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N. 

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed. 

Output

The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer "-1".

Sample Input

3 2 1
2 2 3
2 3 1
2 1 2

Sample Output

0

题目大意:电车从a到b,在每个路口有很多岔道,只有第一个不用拨动开关,其他的都需要拨动

解题思路:主要问题是建图,每个路口第一个出去的轨道权值设为0,其他均为1;

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
#include <stack>
#define inf 0x3f3f3f3f
using namespace std;
struct edge
{
    int from,to,w,next;
}e[10100];
int dis[120],n,m,l[120],head[120];
bool vis[120];
void spfa(int a)
{
    int i;
    stack<int> q;
    memset(dis,inf,sizeof(dis));
    memset(vis,0,sizeof(vis));
    dis[a]=0;
    vis[a]=1;
    q.push(a);
    int u;
    while(!q.empty())
    {
        u=q.top();
        q.pop();
        vis[u]=0;
        for(i=head[u];i!=-1;i=e[i].next)
        {
            if(dis[e[i].to]>dis[e[i].from]+e[i].w)
            {
                dis[e[i].to]=dis[e[i].from]+e[i].w;
                if(!vis[e[i].to])
                {
                    vis[e[i].to]=1;
                    q.push(e[i].to);
                }
            }
        }
    }
}
int T;
void addedge(int u,int v,int w)
{
    e[T].from=u;
    e[T].to=v;
    e[T].w=w;
    e[T].next=head[u];
    head[u]=T++;
}
int main()
{
    int i,a,b,j,w,no;
    memset(head,-1,sizeof(head));
    scanf("%d %d %d",&n,&a,&b);
    T=0;
    for(i=1;i<=n;i++)
    {
        scanf("%d",&w);
        for(j=1;j<=w;j++)
        {
            scanf("%d",&no);
            if(j!=1) addedge(i,no,1);
            else addedge(i,no,0);
        }
    }
    spfa(a);
    if(dis[b]==inf) printf("%d\n",-1);
    else printf("%d\n",dis[b]);
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值