Max Sum Plus Plus

Now I think you have got an AC in Ignatius.L's "Max Sum" problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem. 

Given a consecutive number sequence S 1, S 2, S 3, S 4 ... S x, ... S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + ... + S j (1 ≤ i ≤ j ≤ n). 

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + ... + sum(i m, j m) maximal (i x ≤ iy ≤ j x or i x ≤ j y ≤ j x is not allowed). 

But I`m lazy, I don't want to write a special-judge module, so you don't have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^ 

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S2, S 3 ... S n
Process to the end of file. 

Output

Output the maximal summation described above in one line. 

Sample Input

1 3 1 2 3
2 6 -1 4 -2 3 -2 3

Sample Output

6
8

Hint

Huge input, scanf and dynamic programming is recommended.

        
 题目大意:输入一串数字第一个问取n段连续数字,n段每段求和,再把这些和加起来,问最大值是多少

题解:h[i][j]为在包含第i个元素的时候,有j个段的最大和而且第i个元素和h[i-1][j]的最后一段为连续的,g[i][j]为不一定包含第i个元素的,有j个段的最大和的情况而且第i个元素和g[i-1][j]的最后一段是不连续的,假设这两个二维数组在第i个元素的时候已经满足在第i个元素之前这段的所有条件,就是满足有j段和在第i个元素之前的一段中为最大的和,所以我们到第i个元素的时候,看看是否选择这第i个元素,所以就写出所有可能的情况。

h[i][j]=max(h[i-1][j],g[i-1][j-1])+w[i](w[i]为每一个元素的值),g[i][j]=max(h[i][j],g[i-1][j]);

因为二维数组空间太大了,所以就用一维数组,h[j]=max(h[j],g[j-1])+w[i],g[j]=max(h[j],g[j]);

#include <iostream>
#include <algorithm>
#include <stdio.h>
#include <stdlib.h>

using namespace std;

long long int g[10000008],h[10000008];
int w[10000008];
int main()
{
    int t,n,i,j;
    while(scanf("%d %d",&t,&n)!=EOF)
    {
        for(i=1; i<=n; i++)
        {
            scanf("%d",&w[i]);
        }
        for(i=1; i<=t; i++)
        {
            g[i]=h[i]=-999999999;
        }
        for(i=1; i<=n; i++)
        {
            for(j=t; j>=1; j--)
            {
                h[j]=max(h[j],g[j-1])+w[i];
                g[j]=max(h[j],g[j]);
            }
        }
        printf("%lld\n",g[t]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值