Phalanx HDU - 2859

Today is army day, but the servicemen are busy with the phalanx for the celebration of the 60th anniversary of the PRC. 
A phalanx is a matrix of size n*n, each element is a character (a~z or A~Z), standing for the military branch of the servicemen on that position. 
For some special requirement it has to find out the size of the max symmetrical sub-array. And with no doubt, the Central Military Committee gave this task to ALPCs. 
A symmetrical matrix is such a matrix that it is symmetrical by the “left-down to right-up” line. The element on the corresponding place should be the same. For example, here is a 3*3 symmetrical matrix: 
cbx 
cpb 
zcc

Input

There are several test cases in the input file. Each case starts with an integer n (0<n<=1000), followed by n lines which has n character. There won’t be any blank spaces between characters or the end of line. The input file is ended with a 0.

Output

Each test case output one line, the size of the maximum symmetrical sub- matrix. 

Sample Input

3
abx
cyb
zca
4
zaba
cbab
abbc
cacq
0

Sample Output

3
3

题目大意:n*n的矩阵,要求找出沿从左下到右上的直线,直线两边对称的最大矩阵

解题思路:从最右上角开始,第一行和最后一列一定为1,然后往左下推,每次i+1,j-1,然后看新增加的的这一行和这一列是否对称,最大对称长度为多多少,如果比右上角小一层的矩阵多一个以上,那么一定是右上角小一层的矩阵+1,如果小于,就是他推得最大数;

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int mx,i,j,a[1009][1009],n,dp[1009][1009],I,J,num;
int main()
{
    while(~scanf("%d",&n)&&n)
    {
        getchar();
        mx=1;
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                a[i][j]=getchar();
            }
            getchar();
        }
        for(i=0;i<n;i++)
        {
            for(j=0;j<n;j++)
            {
                if(i==0||j==n-1)
                {
                    dp[i][j]=1;
                    continue;
                }
                I=i;
                J=j;
                num=0;
                while(I>=0&&J<=n-1&&a[I][j]==a[i][J])
                {
                    num++;
                    I--;
                    J++;
                }
                if(num>=dp[i-1][j+1]+1)
                {
                    dp[i][j]=dp[i-1][j+1]+1;
                }
                else
                {
                    dp[i][j]=num;
                }
                mx=max(dp[i][j],mx);
            }
        }
        printf("%d\n",mx);
    }
    return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值