二分图最大分配

Adam and Eve play a card game using a regular deck of 52 cards. The rules are simple. The players sit on opposite sides of a table, facing each other. Each player gets k cards from the deck and, after looking at them, places the cards face down in a row on the table. Adam’s cards are numbered from 1 to k from his left, and Eve’s cards are numbered 1 to k from her right (so Eve’s i:th card is opposite Adam’s i:th card). The cards are turned face up, and points are awarded as follows (for each i ∈ {1, . . . , k}):
• If Adam’s i:th card beats Eve’s i:th card, then Adam gets one point.
• If Eve’s i:th card beats Adam’s i:th card, then Eve gets one point.
• A card with higher value always beats a card with a lower value: a three beats a two, a four beats a three and a two, etc. An ace beats every card except (possibly) another ace.
• If the two i:th cards have the same value, then the suit determines who wins: hearts beats all other suits, spades beats all suits except hearts, diamond beats only clubs, and clubs does not beat any suit.

For example, the ten of spades beats the ten of diamonds but not the Jack of clubs. This ought to be a game of chance, but lately Eve is winning most of the time, and the reason is that she has started to use marked cards. In other words, she knows which cards Adam has on the table before he turns them face up. Using this information she orders her own cards so that she gets as many points as possible.

Your task is to, given Adam’s and Eve’s cards, determine how many points Eve will get if she plays optimally.
Input
There will be several test cases. The first line of input will contain a single positive integer N giving the number of test cases. After that line follow the test cases.

Each test case starts with a line with a single positive integer k ≤ 26 which is the number of cards each player gets. The next line describes the k cards Adam has placed on the table, left to right. The next line describes the k cards Eve has (but she has not yet placed them on the table). A card is described by two characters, the first one being its value (2, 3, 4, 5, 6, 7, 8 ,9, T, J, Q, K, or A), and the second one being its suit (C, D, S, or H). Cards are separated by white spaces. So if Adam’s cards are the ten of clubs, the two of hearts, and the Jack of diamonds, that could be described by the line

TC 2H JD
Output
For each test case output a single line with the number of points Eve gets if she picks the optimal way to arrange her cards on the table.
Sample Input
3
1
JD
JH
2
5D TC
4C 5H
3
2H 3H 4H
2D 3D 4D
Sample Output
1
1
2

扑克牌比较,总是下面的一组比较上面的一组然后,大于的话,就加1.先比较前面的数,如果前面的数一样大,就比较后面的花色。

 #include<stdio.h>
 #include<string.h>
 #include<algorithm>
 using namespace std;
 int book[100100];
 int wx(char a[])
     {
         if(a[0]>='2'&&a[0]<='9')
         return a[0]-'2';
         else if(a[0]=='T')
         return 10;
         else if(a[0]=='J')
         return 11;
         else if(a[0]=='Q')
         return 12;
         else if(a[0]=='K')
         return 13;
         else if(a[0]=='A')
         return 14;//考虑为什么A用14代替。哈哈 
     }
         int wy(char b[])
    {
            if(b[1]=='C')
                return 1;
             else if(b[1]=='D')
                return 2;
              else if(b[1]=='S')
               return 3;
            else if(b[1]=='H')
               return 4;
    }
        struct node
    {
        int x,y;
    }p[10010],q[10010];//开一个结构体,利于sort排序。 
        bool cmp(node a,node b)
    {
               if(a.x==b.x)
              return a.y>b.y;
                 return a.x>b.x;
    }
   int main()
 {
     int t;
     scanf("%d",&t);
     while(t--)//几组数 
  {
        memset(book,0,sizeof(book));
        int i;
        char o[100]; 
        int n,ans=0;
        scanf("%d",&n);
        for(i=0;i<n;i++)
        {
            scanf("%s",&o);
            p[i].x=wx(o);//调用上面的函数,将字符转化成数字。 
            p[i].y=wy(o);//调用上面的函数,将字符转化成数字。(辨别数组a【0】,b【1】的区别,例如JH,a【0】代表了J,b【1】到标了H) 
        }
      for(i=0;i<n;i++)
    {
        scanf("%s",&o);
        q[i].x=wx(o);
        q[i].y=wy(o);
    }
    sort(p,p+n,cmp);
    sort(q,q+n,cmp);
    int k;
    for(i=0;i<n;i++)
    {
        for(k=0;k<n;k++)
        {
            if(book[k]==0)
            {
                if(q[i].x>p[k].x||(q[i].x==p[k].x&&q[i].y>p[k].y))
                {
                    book[k]=1;
                    k++;
                    ans++;
                    break;
                }
            }
        }
    }
       printf("%d\n",ans);
  }
       return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
人工智能关于最大二分图的程序代码: #include<stdio.h> #include<string.h> main() { bool map[100][300]; int i,i1,i2,num,num1,que[300],cou,stu,match1[100],match2[300],pque,p1,now,prev[300],n; scanf("%d",&n); for(i=0;i<n;i++) { scanf("%d%d",&cou;,&stu;); memset(map,0,sizeof(map)); for(i1=0;i1<cou;i1++) { scanf("%d",&num;); for(i2=0;i2<num;i2++) { scanf("%d",&num1;); map[i1][num1-1]=true; } } num=0; memset(match1,int(-1),sizeof(match1)); memset(match2,int(-1),sizeof(match2)); for(i1=0;i1<cou;i1++) { p1=0; pque=0; for(i2=0;i2<stu;i2++) { if(map[i1][i2]) { prev[i2]=-1; que[pque++]=i2; } else prev[i2]=-2; } while(p1<pque) { now=que[p1]; if(match2[now]==-1) break; p1++; for(i2=0;i2<stu;i2++) { if(prev[i2]==-2&&map;[match2[now]][i2]) { prev[i2]=now; que[pque++]=i2; } } } if(p1==pque) continue; while(prev[now]>=0) { match1[match2[prev[now]]]=now; match2[now]=match2[prev[now]]; now=prev[now]; } match2[now]=i1; match1[i1]=now; num++; } if(num==cou) printf("YES\n"); else printf("NO\n"); } } dfs实现过程: #include<stdio.h> #include<string.h> #define MAX 100 bool map[MAX][MAX],searched[MAX]; int prev[MAX],m,n; bool dfs(int data) { int i,temp; for(i=0;i<m;i++) { if(map[data][i]&&!searched[i]) { searched[i]=true; temp=prev[i]; prev[i]=data; if(temp==-1||dfs(temp)) return true; prev[i]=temp; } } return false; } main() { int num,i,k,temp1,temp2,job; while(scanf("%d",&n)!=EOF&&n!=0) { scanf("%d%d",&m,&k); memset(map,0,sizeof(map)); memset(prev,int(-1),sizeof(prev)); memset(searched,0,sizeof(searched)); for(i=0;i<k;i++) { scanf("%d%d%d",&job;,&temp1;,&temp2;); if(temp1!=0&&temp2;!=0) map[temp1][temp2]=true; } num=0; for(i=0;i<n;i++) { memset(searched,0,sizeof(searched)); dfs(i); } for(i=0;i<m;i++) { if(prev[i]!=-1) num++; } printf("%d\n",num); } }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值