素数筛

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo’s length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input
Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output
For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input
3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output
Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

#include <string.h>
#include <stdio.h>
#include <algorithm>
 #include <stdlib.h>
using namespace std;
const long long maxn=1000005;
 long long save[maxn];
void init()
{
  long long i,j;
   for(i=1;i<maxn;i++)
   {
       save[i]=i;
    }
    for(i=2;i<maxn;i++)
 {
    if(save[i]==i)
	{
        for(j=i;j<maxn;j+=i)
		{
              save[j]=save[j]*(i-1)/i;
            }
          }
      }
  }
     int main(){
   long long i,j,k,t,n,cnt=1;
   init();
   scanf("%lld",&t);
while(t--)
{
    scanf("%lld",&n);
    long long result=0;
    for(i=1;i<=n;i++)
	{
        scanf("%lld",&k);
        if(k==1){
            result=result+2;
            continue;
        }
        for(j=k;j<=maxn;j++)
		{
            if(save[j]>=k)
			{
                result += j;
                break;
            }
        }
    }
    printf("Case %lld: %lld Xukha\n",cnt,result);
    cnt++;
}
return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值