HDU - 1019 Least Common Multiple

Least Common Multiple


Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51937 Accepted Submission(s): 19700


Problem Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.


Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 … nm where m is the number of integers in the set and n1 … nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.


Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.


Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1


Sample Output

105
10296


题目大意就是找出n个数的最小公倍数,然后那个32 - bit 应该是长整型(long long)

主要的做题思路就是不断的求最小公倍数

#include<iostream>
#include<stdio.h>
using namespace std;
#define ll long long
ll gcd (ll a ,ll b )//辗转相除(迭代法)
{
    while( a>0 )
    {
        ll c = b % a;
        b = a ;
        a = c ;
    }
    return b ;
}
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        ll n;
        scanf("%lld",&n);
        ll ans = 1;
        while(n--)
        {
            ll m;
            scanf("%lld",&m);
            if(ans%m==0)
                continue;
            ll g=gcd(ans,m);
            ans = ans*m/g; //这里用到了gcd (a,b)*lcm(a,b)=a*b 
        }
        printf("%lld\n",ans);
    }
    return 0;
}
下面是整理出的一些求GCD(最大公因数)的方法:

1 . 递归法:欧几里得算法 -> 辗转相除法 gcd( a , b ) = gcd( b , a mod b )

int gcd ( int a , int b)
{
    //if( a > b )  swap( a , b )
    return (b==0) ? a : gcd ( b , a % b );
}

2 . 迭代法(递推法):欧几里得算法 / 较快

int gcd ( int a , int b )
{
    while( a>0 )
    {
        int c = b % a;
        b = a ;
        a = c ;
    }
    return b ;
}

3 . 连续整数试探法 // 就是最为普通的遍历

int gcd ( int a , int b )
{
    if( a > b )    // 使 a < b
    {
        int temp = a ;
        a = b ;
        b = temp ;
    }
    int t = a ;
    while( a % t || b % t)
    {
        t - - ;   
    }
    return t ;
}
LCM(最小公倍数)

基于GCD 由 gcd ( a , b ) × lcm( a , b ) = a × b 得到 LCM

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值