17 多校 3 - 1008 - RXD and math(HDU 6063)



RXD and math

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 984    Accepted Submission(s): 540


Problem Description
RXD is a good mathematician.
One day he wants to calculate:
i=1nkμ2(i)×nki

output the answer module  109+7 .
1n,k1018
μ(n)=1(n=1)

μ(n)=(1)k(n=p1p2pk)

μ(n)=0(otherwise)

p1,p2,p3pk  are different prime numbers
 

Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers  n,k .
 

Output
For each test case, output "Case #x: y", which means the test case number and the answer.
 

Sample Input
   
   
10 10
 

Sample Output
   
   
Case #1: 999999937
 

  找规律是个好方法!

可以打表发现公式可转换为 n^k

#include<iostream>
#include<string.h>
#include<stdio.h>
using namespace std;
#define ll long long
ll n,k,mod = 1e9 + 7;
ll qkm(ll n,ll m)
{
    ll base = n;
    n = 1;
    while(m)
    {
        if(m%2)
            n = (n * base) % mod;
        base = (base * base) % mod;
        m/=2;
    }
    return n;
}
int main()
{
    int cas = 0;
    while(scanf("%lld%lld",&n,&k)!=EOF)
        printf("Case #%d: %lld\n",++cas,qkm(n%mod,k));
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值