HDU 6063 RXD and math+(快速幂)+多校联赛第三场



RXD and math

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 416    Accepted Submission(s): 210


Problem Description
RXD is a good mathematician.
One day he wants to calculate:
i=1nkμ2(i)×nki

output the answer module  109+7 .
1n,k1018
μ(n)=1(n=1)

μ(n)=(1)k(n=p1p2pk)

μ(n)=0(otherwise)

p1,p2,p3pk  are different prime numbers
 

Input
There are several test cases, please keep reading until EOF.
There are exact 10000 cases.
For each test case, there are 2 numbers  n,k .
 

Output
For each test case, output "Case #x: y", which means the test case number and the answer.
 

Sample Input
      
      
10 10
 

Sample Output
      
      
Case #1: 999999937
 

Source
 

Recommend
liuyiding   |   We have carefully selected several similar problems for you:   6066  6065  6064  6063  6062 


官方题解


注意到一个数字 xx 必然会被唯一表示成 a^2\times ba2×b 的形式.其中 |\mu(b)| = 1μ(b)=1 。 所以这个式子会把 [1, n^k][1,nk] 的每个整数恰好算一次. 所以答案就是 n^knk ,快速幂即可. 时间复杂度 O(\log k)O(logk) .
当时做题是想的是打表,到现在,也不知道怎么推出了的,

正场比赛下来,求安慰

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
#include<math.h>
using namespace std;
int main()
{
    long long n,k;
    int T=1;
    while(scanf("%lld%lld",&n,&k)!=EOF)
    {
        long long sum=1;
        n=n%1000000007;
        while(k)
        {
            if(k%2==0)
            {
                n=n*n%1000000007;
                k=k/2;
            }
            else
            {
                sum=(sum%1000000007)*(n%1000000007);
                sum=sum%1000000007;
                k--;
            }
        }

        printf("Case #%d: %lld\n",T++,sum);
    }
}





评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值