HDU - 1247 - Hat's Words(字典树)

Hat’s Words

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15814    Accepted Submission(s): 5637


Problem Description
A hat’s word is a word in the dictionary that is the concatenation of exactly two other words in the dictionary.
You are to find all the hat’s words in a dictionary.
 

Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will be no more than 50,000 words.
Only one case.
 

Output
Your output should contain all the hat’s words, one per line, in alphabetical order.
 

Sample Input
  
  
a ahat hat hatword hziee word
 

Sample Output
  
  
ahat hatword
 

题意:给一组单词,找出可以分为两部分且两部分单词均在该组单词中的单词


没有准确的输入数据写的就有点虚。

字典树,先建树,再把每个单词分开两部分找,是不是有这样的出现过。

因为输入是按字典序的所以也不用自己再来排序什么的,直接用输入的顺序就行了。

#include<iostream>
#include<stdio.h>
#include<string.h>
#include<string>
#include<vector>
using namespace std;
char s[50000+100][100];
int cnt = 0;
struct node
{
    bool flag;
    char c;
    vector<node*>next;
    node()
    {
        flag = false;
        next.clear();
        c = 0;
    }
}*tree,*add;
bool find_and_insert(node *now,char *str,int x,int len,int ope)
{
    if(x==len)
    {
        if(ope)
            now->flag = true;
        return now->flag;
    }
    for(int i=0;i<now->next.size();i++)
    {
        if(now->next[i]->c!=str[x])
            continue;
        return find_and_insert(now->next[i], str,x+1,len, ope);
    }
    if(ope)
    {
        add = new node;
        add->c = str[x];
        now->next.push_back(add);
        return find_and_insert(add, str,x+1,len, ope);
    }
    return 0;
}
int main()
{
    tree = new node;
    while(scanf("%s",s[cnt])!=EOF)
        find_and_insert(tree,s[cnt],0,(int)strlen(s[cnt]),1),cnt++;
    for(int i=0;i<cnt;i++)
    {
        for(int j=1;j<strlen(s[i]);j++)//遍历所有的分开两种的可能
        {
            if(find_and_insert(tree, s[i], 0, j, 0)&&find_and_insert(tree, s[i], j, strlen(s[i]), 0))//判断前后两部分是否存在
            {
                printf("%s\n",s[i]);
                break;
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值