D - Cable master POJ - 1064

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it. 
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible. 
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled. 
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point. 
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39

Sample Output

2.00

题目大意:

给出几条绳,求出能剪成给定条数的最大长度,不过见不到给定的条数,则输出0.00;

思路:
寻找一个数,明显是二分,所以我们要确定二分的对象,这里明显是要求的绳子长度。这里有一个坑点和玄学点,坑点就是不能四舍五入啊,也就是不能直接用%.3f输出,玄学点就是二分那里不能写成精度,要直接写循环次数(别问我为什么,我也不知道)

下面是ac代码:

#include<cstdio>
#include<string.h>
#include<cmath>
#define inf 1000000.0
using namespace std;
double a[10000];
int n,s;
int fuck(double x)
{
    int sum=0;
    for(int i=0;i<n;i++)
    {
        sum+=(int)(a[i]/x);
    }
    if(sum>=s)
        return 1;
    else
        return 0;
}
int main()
{
    while(scanf("%d%d",&n,&s)==2&&n&&s)
    {
        for(int i=0;i<n;i++)
            scanf("%lf",&a[i]);
        double low=0,high=inf,mid;
        for(int i=0;i<=100;i++)
        {
            mid=(low+high)/2;
            if(fuck(mid))
                low=mid;
            else
                high=mid;
        }
        low=floor(low*100)/100;
        printf("%.2f\n",low);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值