Cable master

 Cable master


Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology - i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.
To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants as far from each other as possible.
The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not known and the Cable Master is completely puzzled.
You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input
The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output
Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal point.
If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39
Sample Output
2.00

题意:有n块木板(以下n行输入),要把这n块木板分成k块相等长度的小木板,问小木板的最长长度为多少。

思路:一开始本来想的是将每组数据都乘100,然后再从整数范围内二分,最后再除100,但是这样会丢失精度,因此要直接从double范围内直接二分即可。

提示:这个题目有两个坑点,第一点就是需要用C++交题而不能用G++,我也不知道为什么,但是就是这样。第二个坑点就是保留两位有效数字会自动四舍五入,为了避免这样的情况我一开始用了r-0.005,但是这样不行(可以尝试输出一下(4.03/2和2.03/2),我还是不知道为什么会这样,因此要用floor(r*100)/100。

AC代码:

#include<iostream>
#include<cstdio>
#include<cmath>
#include<string>
double a[100005];
using namespace std;
bool ck(double m,int n,int k){
    int sum=0;
    for(int i=0;i<n;i++){
        sum+=(int)(a[i]/m);
    }
    return sum>=k;
}
int main()
{
    int n,k;
    while(~scanf("%d%d",&n,&k)){
        for(int i=0;i<n;i++){
            scanf("%lf",&a[i]);
        }
        double l=0,r=100005,mid=0;
        int i=1000;
        while(i--){
            mid = (l+r)/2;
            if(ck(mid,n,k))
                l = mid;
            else
                r = mid;
        }
        printf("%0.2lf\n",(floor(r*100))/100);
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值