HDU1089-1096输入输出基础题组

1089

1 5
10 20

Sample Output
6
30

代码

#include <iostream>
using namespace std;
int main()
{
    int a,b,sum;
    while(cin>>a>>b)
    {
        sum=a+b;
        cout<<sum<<endl;
    }
    return 0;
}

1090

Sample Input
2
1 5
10 20

Sample Output
6
30

代码

#include <iostream>
using namespace std;
int main()
{
    int a,b,sum;
    while(cin>>a>>b)
    {
        sum=a+b;
        cout<<sum<<endl;
    }
    return 0;
}

1091

Sample Input
1 5
10 20
0 0

Sample Output
6
30

代码

#include <iostream>
using namespace std;
int main()
{
    int a,b,sum;
    while(cin>>a>>b)
    {
        if(a==0&&b==0)
            break;
        sum=a+b;
        cout<<sum<<endl;
    }
    return 0;
}

1092

Sample Input
4 1 2 3 4
5 1 2 3 4 5
0

Sample Output
10
15

代码

#include <iostream>
using namespace std;
int main()
{
    while(1)
    {
        int a[1001]={0};
        int sum=0;
        cin>>a[0];
        if(a[0]==0)
            break;
        for(int i=1;i<=a[0];i++)
        {
            cin>>a[i];
            sum+=a[i];
        }
        cout<<sum<<endl;
    }
    return 0;
}

1093

Sample Input
2
4 1 2 3 4
5 1 2 3 4 5

Sample Output
10
15

代码

#include <iostream>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int a[1001]={0};
        int sum=0;
        cin>>a[0];
        for(int i=1;i<=a[0];i++)
        {
            cin>>a[i];
            sum+=a[i];
        }
        cout<<sum<<endl;
    }
    return 0;
}

1094

Sample Input
4 1 2 3 4
5 1 2 3 4 5

Sample Output
10
15

代码

#include <iostream>
using namespace std;
int main()
{
    int a[1001]={0};
    while(cin>>a[0])
    {
        int sum=0;
        for(int i=1;i<=a[0];i++)
        {
            cin>>a[i];
            sum+=a[i];
        }
        cout<<sum<<endl;
    }
    return 0;
}

1095

Sample Input
1 5
10 20

Sample Output
6

30

代码

#include <iostream>
using namespace std;
int main()
{
    int a,b;
    while(cin>>a>>b)
    {
        int sum=0;
        sum=a+b;
        cout<<sum<<endl;
        cout<<endl;
    }
    return 0;
}

1096

Sample Input
3
4 1 2 3 4
5 1 2 3 4 5
3 1 2 3

Sample Output
10

15

6

代码

#include <iostream>
using namespace std;
int main()
{
    int t;
    cin>>t;
    while(t--)
    {
            int a[1001]={0};
            int sum=0;
            cin>>a[0];
            for(int i=1;i<=a[0];i++)
            {
                cin>>a[i];
                sum+=a[i];
            }
            cout<<sum<<endl;
            if(t!=0)
            cout<<endl;
            else
            break;
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值