HDU 1002 A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input
2
1 2
112233445566778899 998877665544332211
Sample Output
Case 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
int main()
{
 int t;
 scanf("%d",&t);
 for(int k=1;k<=t;k++)
 {
  char a[1010],b[1010];//数值太大,不能以int、long等输入
  int sum[1010]={0};//初始化sum数组,方便后续做加法时进位
  scanf("%s %s",a,b);
  int lena=strlen(a);//计算数组长度
  int lenb=strlen(b);
  if(lena>=lenb)//判断哪个大数位数大
  {
   int i,j;
   for(i=lena-1,j=lenb-1;i>=0,j>=0;i--,j--)//从后往前加
   {
    sum[i+1]+=(a[i]-'0')+(b[j]-'0');//把字符串转换成数字后加到sum数组里
    if(sum[i+1]>9)//判断是否需要进位
    {
     sum[i+1]-=10;//i+1是因为不知道最后是否需要进位,提前留出位置
     sum[i]=1;
    }
   }
   for(;i>=0;i--) 
   {
    sum[i+1]+=(a[i]-'0');
    if(sum[i+1]>9)
    {
     sum[i+1]-=10;
     sum[i]=1;
    }
   } 
  }
  else
  {
   int i,j;
   for(i=lenb-1,j=lena-1;i>=0,j>=0;i--,j--)
   {
    sum[i+1]+=(b[i]-'0')+(a[j]-'0');
    if(sum[i+1]>9)
    {
     sum[i+1]-=10;
     sum[i]=1;
    }
   }
   for(;i>=0;i--) 
   {
    sum[i+1]+=(b[i]-'0');
    if(sum[i+1]>9)
    {
     sum[i+1]-=10;
     sum[i]=1;
    }
   } 
  }
  printf("Case %d:\n%s + %s = ",k,a,b);
  if(sum[0]==0&&sum[1]==0)//结果是0,特殊处理
   printf("0");
  else if(sum[0]==0)//第一位是0
   for(int i=1;i<=max(lena,lenb);i++)
    printf("%d",sum[i]);
  else//第一位不是0
   for(int i=0;i<=max(lena,lenb);i++)
    printf("%d",sum[i]);
  if(k!=t) printf("\n\n");//注意题目中格式要求
  else printf("\n");
 }
    return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值