【bzoj3011】[Usaco2012 Dec]Running Away From the Barn

Description

It’s milking time at Farmer John’s farm, but the cows have all run away! Farmer John needs to round them all up, and needs your help in the search. FJ’s farm is a series of N (1 <= N <= 200,000) pastures numbered 1…N connected by N - 1 bidirectional paths. The barn is located at pasture 1, and it is possible to reach any pasture from the barn. FJ’s cows were in their pastures this morning, but who knows where they ran to by now. FJ does know that the cows only run away from the barn, and they are too lazy to run a distance of more than L. For every pasture, FJ wants to know how many different pastures cows starting in that pasture could have ended up in. Note: 64-bit integers (int64 in Pascal, long long in C/C++ and long in Java) are needed to store the distance values.

给出以1号点为根的一棵有根树,问每个点的子树中与它距离小于l的点有多少个。
Input

  • Line 1: 2 integers, N and L (1 <= N <= 200,000, 1 <= L <= 10^18)

    • Lines 2..N: The ith line contains two integers p_i and l_i. p_i (1 <= p_i < i) is the first pasture on the shortest path between pasture i and the barn, and l_i (1 <= l_i <= 10^12) is the length of that path.

Output

  • Lines 1..N: One number per line, the number on line i is the number pastures that can be reached from pasture i by taking roads that lead strictly farther away from the barn (pasture 1) whose total length does not exceed L.

Sample Input

4 5

1 4

2 3

1 5

Sample Output

3

2

1

1

OUTPUT DETAILS: Cows from pasture 1 can hide at pastures 1, 2, and 4. Cows from pasture 2 can hide at pastures 2 and 3. Pasture 3 and 4 are as far from the barn as possible, and the cows can hide there.

题解
可并堆,以它到根的距离最大值堆顶,每次判断距离是否小于等于l,否则删除。

代码

#include<cstdio>
#include<algorithm>
#include<cmath>
#include<iostream>
#include<cstring>
#include<queue>
typedef long long ll;
using namespace std;
inline int read()
{
    int x=0;char ch=getchar();
    while (ch<'0'||ch>'9') ch=getchar();
    while (ch>='0'&&ch<='9') x=x*10+ch-'0',ch=getchar();
    return x;
}
int n,Head[200005],ret[200005],Next[200005];;
ll l,d[200005],len[200005];
int f[200005],tot,ls[200005],rs[200005],dis[200005];
int ans[200005];
void ins(int u,int v,ll w)
{   
    ret[++tot]=v;len[tot]=w;
    Next[tot]=Head[u];Head[u]=tot;
}
int merge(int a,int b)
{
    if (!a) return b;
    if (!b) return a;
    if (d[a]<d[b]) swap(a,b);
    rs[a]=merge(rs[a],b);
    f[rs[a]]=a;
    if (dis[rs[a]]>dis[ls[a]]) swap(ls[a],rs[a]);
    dis[a]=dis[rs[a]]+1;
    return a;
}
void dfs(int u)
{
    ans[u]=1;
    for (int i=Head[u];i;i=Next[i])
    {
        int v=ret[i];
        d[v]=d[u]+len[i];
        dfs(v);
        ans[u]+=ans[v];
        f[u]=merge(f[u],f[v]);
        while (d[f[u]]-d[u]>l)
        {
            ans[u]--;
            f[u]=merge(ls[f[u]],rs[f[u]]);
        }
    }
}
int main()
{
    n=read();scanf("%lld",&l);
    for (int i=2;i<=n;i++)
    {
        int f;ll w;
        scanf("%d%lld",&f,&w);
        ins(f,i,w);
    }
    for (int i=1;i<=n;i++) f[i]=i;
    dfs(1);
    for (int i=1;i<=n;i++) printf("%d\n",ans[i]);
    return 0;
}
深度学习是机器学习的一个子领域,它基于人工神经网络的研究,特别是利用多层次的神经网络来进行学习和模式识别。深度学习模型能够学习数据的高层次特征,这些特征对于图像和语音识别、自然语言处理、医学图像分析等应用至关重要。以下是深度学习的一些关键概念和组成部分: 1. **神经网络(Neural Networks)**:深度学习的基础是人工神经网络,它是由多个层组成的网络结构,包括输入层、隐藏层和输出层。每个层由多个神经元组成,神经元之间通过权重连接。 2. **前馈神经网络(Feedforward Neural Networks)**:这是最常见的神经网络类型,信息从输入层流向隐藏层,最终到达输出层。 3. **卷积神经网络(Convolutional Neural Networks, CNNs)**:这种网络特别适合处理具有网格结构的数据,如图像。它们使用卷积层来提取图像的特征。 4. **循环神经网络(Recurrent Neural Networks, RNNs)**:这种网络能够处理序列数据,如时间序列或自然语言,因为它们具有记忆功能,能够捕捉数据中的时间依赖性。 5. **长短期记忆网络(Long Short-Term Memory, LSTM)**:LSTM 是一种特殊的 RNN,它能够学习长期依赖关系,非常适合复杂的序列预测任务。 6. **生成对抗网络(Generative Adversarial Networks, GANs)**:由两个网络组成,一个生成器和一个判别器,它们相互竞争,生成器生成数据,判别器评估数据的真实性。 7. **深度学习框架**:如 TensorFlow、Keras、PyTorch 等,这些框架提供了构建、训练和部署深度学习模型的工具和库。 8. **激活函数(Activation Functions)**:如 ReLU、Sigmoid、Tanh 等,它们在神经网络中用于添加非线性,使得网络能够学习复杂的函数。 9. **损失函数(Loss Functions)**:用于评估模型的预测与真实值之间的差异,常见的损失函数包括均方误差(MSE)、交叉熵(Cross-Entropy)等。 10. **优化算法(Optimization Algorithms)**:如梯度下降(Gradient Descent)、随机梯度下降(SGD)、Adam 等,用于更新网络权重,以最小化损失函数。 11. **正则化(Regularization)**:技术如 Dropout、L1/L2 正则化等,用于防止模型过拟合。 12. **迁移学习(Transfer Learning)**:利用在一个任务上训练好的模型来提高另一个相关任务的性能。 深度学习在许多领域都取得了显著的成就,但它也面临着一些挑战,如对大量数据的依赖、模型的解释性差、计算资源消耗大等。研究人员正在不断探索新的方法来解决这些问题。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值