bzoj 3011: [Usaco2012 Dec]Running Away From the Barn (可并堆)

3011: [Usaco2012 Dec]Running Away From the Barn

Time Limit: 10 Sec   Memory Limit: 128 MB
Submit: 309   Solved: 162
[ Submit][ Status][ Discuss]

Description

It's milking time at Farmer John's farm, but the cows have all run away! Farmer John needs to round them all up, and needs your help in the search. FJ's farm is a series of N (1 <= N <= 200,000) pastures numbered 1...N connected by N - 1 bidirectional paths. The barn is located at pasture 1, and it is possible to reach any pasture from the barn. FJ's cows were in their pastures this morning, but who knows where they ran to by now. FJ does know that the cows only run away from the barn, and they are too lazy to run a distance of more than L. For every pasture, FJ wants to know how many different pastures cows starting in that pasture could have ended up in. Note: 64-bit integers (int64 in Pascal, long long in C/C++ and long in Java) are needed to store the distance values. 

给出以1号点为根的一棵有根树,问每个点的子树中与它距离小于l的点有多少个。

Input

 * Line 1: 2 integers, N and L (1 <= N <= 200,000, 1 <= L <= 10^18)

* Lines 2..N: The ith line contains two integers p_i and l_i. p_i (1 <= p_i < i) is the first pasture on the shortest path between pasture i and the barn, and l_i (1 <= l_i <= 10^12) is the length of that path.

Output

* Lines 1..N: One number per line, the number on line i is the number pastures that can be reached from pasture i by taking roads that lead strictly farther away from the barn (pasture 1) whose total length does not exceed L.

Sample Input

4 5
1 4
2 3
1 5

Sample Output

3
2
1
1
OUTPUT DETAILS: Cows from pasture 1 can hide at pastures 1, 2, and 4. Cows from pasture 2 can hide at pastures 2 and 3. Pasture 3 and 4 are as far from the barn as possible, and the cows can hide there.

HINT

Source

[ Submit][ Status][ Discuss]



题解:可并堆+dfs序

初始时每个点都是一个独立的可并堆,在可并堆中维护到该点路径的最大值。

然后按照dfs序倒序合并,每次将节点与他的父亲节点的可并堆合并,如果当前堆得堆顶+边权>L 就将堆顶元素删除,然后合并左右子树,直到<=L为止,然后让当前堆与父亲节点的堆合并。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#define N 200003
#define LL long long
using namespace std;
int fa[N],rch[N],lch[N],q[N],cnt,ans[N],size[N],d[N];
LL val[N],delta[N],k,len[N];
int n,m;
int point[N],next[N<<1],v[N<<1],belong[N],tot;
void add(int x,int y)
{
	tot++; next[tot]=point[x]; point[x]=tot; v[tot]=y;
	tot++; next[tot]=point[y]; point[y]=tot; v[tot]=x;
}
void dfs(int x,int f)
{
	q[++cnt]=x;
	for (int i=point[x];i;i=next[i])
	 if (v[i]!=f)  dfs(v[i],x);
}
void pushdown(int now)
{
	int l=lch[now]; int r=rch[now];
	if (l) {
		delta[l]+=delta[now];
		len[l]+=delta[now];
	}
	if (r) {
		delta[r]+=delta[now];
		len[r]+=delta[now];
	}
	delta[now]=0;
}
int merge(int x,int y)
{
	if (!x) return y;
	if (!y) return x;
	if (len[x]<len[y]) swap(x,y);
	pushdown(x);
	rch[x]=merge(rch[x],y); 
	size[x]=size[lch[x]]+size[rch[x]]+1;
	if(d[lch[x]]<d[rch[x]]) swap(lch[x],rch[x]);
	d[x]=d[rch[x]]+1;
	return x;
}
int main()
{
	freopen("a.in","r",stdin);
	scanf("%d%I64d",&n,&k);
	for (int i=2;i<=n;i++)  {
		int x; LL y; scanf("%d%I64d",&x,&y);
		fa[i]=x; val[i]=y;
		add(x,i);
	}
	dfs(1,0);
	memset(delta,0,sizeof(delta));
	for (int i=1;i<=n;i++) size[i]=1,belong[i]=i,len[i]=0;
	//for (int i=n;i>=1;i--) cout<<q[i]<<" ";
//	cout<<endl;
	for (int i=n;i>=2;i--) {
		int x=q[i];
		ans[x]=size[belong[x]];
		while (size[belong[x]]&&val[x]+len[belong[x]]>k){
			int now=belong[x]; int r1=lch[now]; int r2=rch[now];
			pushdown(now);
			int t=merge(r1,r2); 
			belong[x]=belong[r1]=belong[r2]=t;
		}
		int now=belong[x]; 
		delta[now]+=val[x]; len[now]+=val[x];
		belong[fa[x]]=merge(belong[fa[x]],belong[now]);
	}
	ans[1]=size[belong[1]];
	for (int i=1;i<=n;i++) 
	 printf("%d\n",ans[i]);
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值