数据结构实验之二叉树四:还原二叉树

Problem Description

给定一棵二叉树的先序遍历序列和中序遍历序列,要求计算该二叉树的高度。
Input

输入数据有多组,每组数据第一行输入1个正整数N(1 <= N <= 50)为树中结点总数,随后2行先后给出先序和中序遍历序列,均是长度为N的不包含重复英文字母(区分大小写)的字符串。
Output

输出一个整数,即该二叉树的高度。
Example Input

9
ABDFGHIEC
FDHGIBEAC
Example Output

5
Hint

Author

xam

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
char a[55];
char b[55];
struct node
{
    int data;
    struct node *l, *r;
};
struct node *creat(int n, char *a, char *b)
{
    int i;
    if(n == 0) return NULL;
    struct node *root;
    root = (struct node *) malloc (sizeof(struct node));
    root -> data = a[0];
    for(i = 0; i < n; i++)
    {
        if(b[i] == a[0])
            break;
    }
    root -> l = creat(i, a+1, b);
    root -> r = creat(n-1-i, a+1+i, b+1+i);
    return root;
};
int high(struct node *root)
{
    int d1, d2;
    if(root)
    {
        d1 = high(root -> l);
        d2 = high(root -> r);
        return d1 > d2? d1+1 : d2+1;
    }
    else
        return 0;
}
int main()
{
    int t, n;
    while(~scanf("%d", &t))
    {
        scanf("%s%s", a, b);
        struct node *root;
        n = strlen(a);
        root = creat(n, a, b);
        printf("%d\n", high(root));
    }
    return 0;
}
  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值