HDU 1856 More is better

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex,  the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang's selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.
 

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)
 

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep. 
 

Sample Input
  
  
4 1 2 3 4 5 6 1 6 4 1 2 3 4 5 6 7 8
 

Sample Output
  
  
4 2
Hint
A and B are friends(direct or indirect), B and C are friends(direct or indirect), then A and C are also friends(indirect). In the first sample {1,2,5,6} is the result. In the second sample {1,2},{3,4},{5,6},{7,8} are four kinds of answers.
思路:这题本身很简单,就是求最大的连通分量,但是因为数据过大,这是个梗。本来不想直接开10000000那么大的,后来发现我想多了。。。对Father []siz[]的初始化,一层循环很快的吧,尽管开得很大。。我猜是这样。本来想优化这个数组,但是我用set来存点,再加上一些判断,插入操作,就会比直接开10000000那么大的数组慢很多了,应该是这样。
代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <set>
#include <vector>
#include <algorithm>
#define MAX 10000005
using namespace std;
int Father[MAX];
int siz[MAX];
int p,q,n,w,maxnum;
int Find(int x)
{
    if(Father[x]!= x)
    {
        Father[x] = Find(Father[x]);//路径压缩
    }
    return Father[x];
}
void Merge(int x, int y)//Æðµã  ÖÕµã
{
    int  ix = Find(x);
    int  iy = Find(y);
    if(ix == iy)
    {
        return;
    }
    
//这个处理可以不要的,为了平衡树,使树扁平,是一个优化,当数据很庞大时,可以查找时间,没有这个优化是452ms,有这个优化是436ms,这题感觉差别不是很大。。
if(siz[ix] > siz[iy]) { Father[iy] = ix; siz[ix] += siz[iy]; } else { Father[ix] = iy; siz[iy] += siz[ix]; }}int main(){ while (scanf("%d",&w) != EOF) { maxnum = 1; for (int i = 1; i <= MAX; i++) { Father[i] = i; siz[i] = 1; } for(int i = 0; i < w; i++) { scanf("%d%d",&p, &q); Merge(p,q); } for(int i = 1; i <= MAX-1; i++) { if(i == Father[i]) { if (siz[i] > maxnum) { maxnum = siz[i]; } } } cout << maxnum << endl; } return 0;}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值