问题 D: More is better

题目描述
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

输入
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

输出
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

样例输入 Copy
3
1 3
1 5
2 5
4
3 2
3 4
1 6
2 6

样例输出 Copy
4
5

题目是求数目最多的连通块。为了防止超时,用到了路径压缩。

#include <iostream>
#include<bits/stdc++.h>
int father[10000001];
int findFather(int x)
{
    int y=x;
    while(x!=father[x])
        x=father[x];
    while(y!=father[y])//路径压缩,让所有连着的结点直接指向根结点,缩短路径。
    {
        int t=y;
        y=father[y];
        father[t]=x;
    }
    return x;
}
void Union(int x,int y)
{
    int fatherX=findFather(x);
    int fatherY=findFather(y);
    if(fatherX!=fatherY)
    {
        father[fatherY]=fatherX;
    }
}
int number[10000001];
int main()
{
    int n,i,a,b,maxnumber,maxsum;
    while(scanf("%d",&n)!=EOF)
    {
        if(n==0)printf("1\n");
        else
        {
            memset(number,0,sizeof(number));
            maxnumber=0;
            maxsum=0;
            for(i=1; i<=10000000; i++)father[i]=i;
            for(i=0; i<n; i++)
            {
                scanf("%d %d",&a,&b);
                if(a>maxnumber)maxnumber=a;
                if(b>maxnumber)maxnumber=b;
                Union(a,b);
            }
            for(i=1; i<=maxnumber; i++)
            {
                number[findFather(father[i])]++;//可以findFather(i),也可以findFather(father[i])。
            }
            maxsum=number[1];
            for(i=2; i<=maxnumber; i++)
                if(number[i]>maxsum)maxsum=number[i];
            printf("%d\n",maxsum);
        }
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值