01-复杂度2 Maximum Subsequence Sum


问题描述

Given a sequence of K integers { N1​ , N2 , …, NK }. A continuous subsequence is defined to be { Ni , Ni+1 , …, Nj } where 1≤i≤j≤K. The Maximum Subsequence is the continuous subsequence which has the largest sum of its elements. For example, given sequence { -2, 11, -4, 13, -5, -2 }, its maximum subsequence is { 11, -4, 13 } with the largest sum being 20.

Now you are supposed to find the largest sum, together with the first and the last numbers of the maximum subsequence.


输入格式:

Each input file contains one test case. Each case occupies two lines. The first line contains a positive integer K (≤10000). The second line contains K numbers, separated by a space.

输出格式:

For each test case, output in one line the largest sum, together with the first and the last numbers of the maximum subsequence. The numbers must be separated by one space, but there must be no extra space at the end of a line. In case that the maximum subsequence is not unique, output the one with the smallest indices i and j (as shown by the sample case). If all the K numbers are negative, then its maximum sum is defined to be 0, and you are supposed to output the first and the last numbers of the whole sequence.


输入样例:

10
-10 1 2 3 4 -5 -23 3 7 -21
结尾无空行

输出样例:

10 1 4
结尾无空行

实验代码

#include <iostream>
using namespace std;

//ThisSum,ThisfirstNum,ThislastNum保存当前序列的信息
//MaxSum,firstNum,lastNum保存最大序列的信息
int ThisSum = 0, MaxSum = -1;   
int  firstNum, lastNum;

int MaxSubSum(int a[], int K)
{
    int i;
    int ThisfirstNum = a[0];
    int ThislastNum;
    for (i = 0; i < K; i++)
    {
        ThisSum += a[i];
        ThislastNum = a[i];    //ThislastNum:当前序列的最后一个元素
        if (ThisSum > MaxSum)       //更新最大子序列的信息
        {
            MaxSum = ThisSum;
            firstNum = ThisfirstNum;
            lastNum = ThislastNum;
        }
        else if (ThisSum < 0)
        {
            ThisSum = 0;                    //抛弃当前的子序列
            if (i < K - 1)
                ThisfirstNum = a[i + 1];    //更新当前序列的首元素
        }
    }
    if (MaxSum == -1)
    {
        firstNum = a[0];
        lastNum = a[K - 1];
        MaxSum = 0;
    }
    return 0;
}

int main()
{
    int K;
    cin >> K;
    int* a = new int[10000];
    for (int i = 0; i < K; i++)
        cin >> a[i];
    MaxSubSum(a, K);
    cout << MaxSum << " " << firstNum << " " << lastNum << endl;
    delete[]a;
    return 0;
}

分析与思考

本题和复杂度1那道题基本相同,只是多出了一个输出最大序列首尾元素的要求。这边借鉴在线处理算法的思想,定义了ThisfirstNum和ThislastNum来保存当前序列的首尾元素信息。在ThisSum > MaxSum时,更新最大子序列的三个元素信息就可以了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值