AYIT2017暑假集训第二周周三赛 A - Find The Multiple POJ - 1426

Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
 
 
 
 
 
 
题目意思大概就是给你一个数,然后让你用0和1组成十进制的数去整除他.
这是一道搜索题,用简单的广搜就可以写出来,题目虽然说数很大,其实long long int就可以存下了,
因为只有0,1。所以直接让第一位为1,如果想加上0就直接乘10,加1的话直接乘十加1就行了。
#include<stdio.h>
long long int p[10000000];
int a,b,c,d,i,head,tail;
void bfs()
{
   head=1,tail=2;//用数组模拟队列
    p[1]=1;//设置第一个数为1
    while(head<tail)//如果栈不为空
    {
        if(p[tail-1]%a==0)//如果第一个数就可以整除a就直接输出
            printf("%lld",p[tail-1]);
        else              //然后就进行分情况,只有加1和加0两种情况
        {
            for(i=1; i<=2; i++)
            {
                if(i==1)//当加0时直接乘10,进行存储
                {
                    p[tail]=p[head]*10;
                    if(p[tail]%a==0)
                    {
                        b=1;
                        return;
                    }
                    tail++;
                }
                else
                {
                    p[tail]=p[head]*10+1;//当加1时直接乘10+1,;
                    if(p[tail]%a==0)
                    {
                        b=1;
                        return;
                    }
                    tail++;//两种情况每次进行完就tail++;
                }
            }
        }
        head++;
    }
}
int main()
{
    while(~scanf("%d",&a)&&a!=0)//输入要求解的数
    {
        bfs();//进行广搜
        printf("%lld\n",p[tail]);
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值