B - CA Loves Stick HDU - 5655

CA loves to play with sticks. 
One day he receives four pieces of sticks, he wants to know these sticks can spell a quadrilateral. 
(What is quadrilateral? Click here: https://en.wikipedia.org/wiki/Quadrilateral)
Input
First line contains  T T denoting the number of testcases. 
T T testcases follow. Each testcase contains four integers  a,b,c,d a,b,c,d in a line, denoting the length of sticks. 
1T1000, 0a,b,c,d2631 1≤T≤1000, 0≤a,b,c,d≤263−1
Output
For each testcase, if these sticks can spell a quadrilateral, output "Yes"; otherwise, output "No" (without the quotation marks).
Sample Input
2
1 1 1 1
1 1 9 2
Sample Output
Yes
No
给你四条边让你计算能否在组成一个四边形,当时题目意思没有看懂,后来考完才知道的,由于边的长度比较大,所以用long long存储,在判断时不能用加,只能用减,因为long long相加可能会超过long long的存储范围,出现错误。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        long long int i,p[20];
        for(i=0;i<4;i++)
            scanf("%lld",&p[i]);
        sort(p,p+4);
        if(p[0]==0)
        {
            printf("No\n");continue;
        }
        if(p[3]-p[2]-p[1]<p[0])
            printf("Yes\n");
        else printf("No\n");
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值