poj 1376

The Robot Moving Institute is using a robot in their local store to transport different items. Of course the robot should spend only the minimum time necessary when travelling from one place in the store to another. The robot can move only along a straight line (track). All tracks form a rectangular grid. Neighbouring tracks are one meter apart. The store is a rectangle N x M meters and it is entirely covered by this grid. The distance of the track closest to the side of the store is exactly one meter. The robot has a circular shape with diameter equal to 1.6 meter. The track goes through the center of the robot. The robot always faces north, south, west or east. The tracks are in the south-north and in the west-east directions. The robot can move only in the direction it faces. The direction in which it faces can be changed at each track crossing. Initially the robot stands at a track crossing. The obstacles in the store are formed from pieces occupying 1m x 1m on the ground. Each obstacle is within a 1 x 1 square formed by the tracks. The movement of the robot is controlled by two commands. These commands are GO and TURN. 
The GO command has one integer parameter n in {1,2,3}. After receiving this command the robot moves n meters in the direction it faces. 

The TURN command has one parameter which is either left or right. After receiving this command the robot changes its orientation by 90o in the direction indicated by the parameter. 

The execution of each command lasts one second. 

Help researchers of RMI to write a program which will determine the minimal time in which the robot can move from a given starting point to a given destination. 

Input
The input consists of blocks of lines. The first line of each block contains two integers M <= 50 and N <= 50 separated by one space. In each of the next M lines there are N numbers one or zero separated by one space. One represents obstacles and zero represents empty squares. (The tracks are between the squares.) The block is terminated by a line containing four positive integers B1 B2 E1 E2 each followed by one space and the word indicating the orientation of the robot at the starting point. B1, B2 are the coordinates of the square in the north-west corner of which the robot is placed (starting point). E1, E2 are the coordinates of square to the north-west corner of which the robot should move (destination point). The orientation of the robot when it has reached the destination point is not prescribed. We use (row, column)-type coordinates, i.e. the coordinates of the upper left (the most north-west) square in the store are 0,0 and the lower right (the most south-east) square are M - 1, N - 1. The orientation is given by the words north or west or south or east. The last block contains only one line with N = 0 and M = 0. 
Output
The output contains one line for each block except the last block in the input. The lines are in the order corresponding to the blocks in the input. The line contains minimal number of seconds in which the robot can reach the destination point from the starting point. If there does not exist any path from the starting point to the destination point the line will contain -1. 
Sample Input
9 10
0 0 0 0 0 0 1 0 0 0
0 0 0 0 0 0 0 0 1 0
0 0 0 1 0 0 0 0 0 0
0 0 1 0 0 0 0 0 0 0
0 0 0 0 0 0 1 0 0 0
0 0 0 0 0 1 0 0 0 0
0 0 0 1 1 0 0 0 0 0
0 0 0 0 0 0 0 0 0 0
1 0 0 0 0 0 0 0 1 0
7 2 2 7 south
0 0
Sample Output
12



这道题意思没看懂,在队友的讲解下,我在错误的道路上越走越远,好在自己又走回来了



题目的意思就是给你一个地图,但这个时候地图是一个面,所以要转换一下,就是开一个数组,当遇到不能走的方格的时候即输入值为1的时候,就把此时的 i 与 j看成点,mp[i][j]=mp[i+1][j]=mp[i][j+1]=mp[i+1][j+1]=1;这样标记完成以后,这个面就变成了一个个点,并且此时的机器人是有半径的,所以在走的时候不可能走到边界上.

最重要的部分来了:  这道题目,规定的是你在这一秒内只能完成一个动作,即要不向左右转向,要不向前走1-3步,不能转完向之后立马走三步,这样是不允许的,而且不能转180度.

#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
using namespace std;
struct note
{
    int x,y,id,s;
    bool operator == (const note &a) const
    {
        return a.y==y&&a.x==x;
    }
} st,ed;
int vis[100][100][10];
int mp[100][100];
int n,m;
int dir[4][2]= {0,1,1,0,0,-1,-1,0};
int check(int x,int y,int id)
{
    if(x>0&&y>0&&x<n&&y<m&&vis[x][y][id]==0)
        return 1;
    return 0;
}
int bfs()
{
    queue<note>Q;
    memset(vis,0,sizeof(vis));
    st.s=0;
    Q.push(st);
    note now,temp;
    while(!Q.empty())
    {
        now=Q.front();
        Q.pop();
        if(now==ed)
        {
            printf("%d\n",now.s);
            return 1;
        }

        temp=now;
        temp.s++;
        temp.id=(temp.id+1)%4;
        if(vis[temp.x][temp.y][temp.id]==0)
        {
            vis[temp.x][temp.y][temp.id]=1;
            Q.push(temp);
        }
        temp=now;
        temp.s++;
        temp.id=(temp.id-1+4)%4;
        if(vis[temp.x][temp.y][temp.id]==0)
        {
            vis[temp.x][temp.y][temp.id]=1;
            Q.push(temp);
        }

        for(int i=1; i<=3; i++)
        {
            temp=now;
            temp.x=now.x+dir[temp.id][0]*i;
            temp.y=now.y+dir[temp.id][1]*i;
            if(mp[temp.x][temp.y]==1)break;
            if(check(temp.x,temp.y,temp.id))
            {
                temp.s++;
                vis[temp.x][temp.y][temp.id]=1;
                Q.push(temp);
            }
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n+m))
    {
        int t;
        memset(mp,0,sizeof(mp));
        for(int i=0; i<n; i++)
        {
            for(int j=0; j<m; j++)
            {
                scanf("%d",&t);
                if(t==1)
                {
                    mp[i][j]=mp[i+1][j]=mp[i][j+1]=1;
                    mp[i+1][j+1]=1;
                }
            }
        }
        scanf("%d%d%d%d",&st.x,&st.y,&ed.x,&ed.y);
        char mp[20];
        scanf("%s",mp);
        if(mp[0]=='s')
            st.id=1;
        else if(mp[0]=='e')
            st.id=0;
        else if(mp[0]=='w')
            st.id=2;
        else
            st.id=3;
        if(bfs()==0)
            printf("-1\n");
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值