UESToj 64 CD Making ( 水题

CD Making

Description

Tom has NN songs and he would like to record them into CDs. A single CD can contain at most KK songs. In addition, Tom is very superstitious and he believes the number 13 would bring bad luck, so he will never let a CD contain exactly 1313 songs. Tom wants to use as few CDs as possible to record all these songs. Please help him.

Input

There are TT test cases. The first line gives TT, number of test cases. TT lines follow, each contains NN and KK, number of songs Tom wants to record into CDs, and the maximum number of songs a single CD can contain.

1≤N≤1000,1≤K≤1000

Output

For each test case, output the minimum number of CDs required, if the above constraints are satisfied.

Sample Input

2
5 2
13 13

Sample Output

3
2

题意

一个容器能放K个东西 ,一共给N个东西 ,容器内不能有13的存在 问要多少个容器

题解

考虑的情况比较多 在下14没有考虑到疯狂wa

AC代码

#include <cstdio>
int main()
{
    int T;
    scanf("%d",&T);
    while(T--) {
        int n, k;
        int ans ;
        scanf("%d%d",&n,&k);
        if(k < 13) {
            if(n%k==0) ans = n/k;
            else ans = n/k+1;
        }
        else if(k==13) {
            if(n%12==0) ans = n/12;
            else ans = n/12+1;
        }
        else if(k==14) {
            if(n%k==0) ans = n/k;
            else if(n%k==13) ans = n/k+2;
            else ans = n/k+1; 
        }
        else {
            if(n==13) ans = 2;
            else if(n%k==0) ans = n/k;
            else ans = n/k+1;
        }
        printf("%d\n",ans);
    }
return 0;
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值